Counter-Strike won't work in OpenGL, please help me !

Hi, I have serious problems with running Counter-Strike in OpenGL mode !
The game hangs when it’s finished loading…sigh.

I’ve tried various nvidia and creative drivers, such as 5.22, 5.45, 6.50, 7.78 and at
last 10.80, which actually works, but performance is low and all models turn up
yellow or red.

I have a
Creative TNT2 Ultra card, and i use 5.22 nvida drivers.
256 mb ram (cas 2 latency)
450@500 k6-2
Asus P5-A “Super” socket 7 newest bios
Samsung 3 gb hd

Win 98
DirectX 8
1.68 ali agp driver
High fps cs models

Other info
FSB 110 mhz (stable)
Half-life works perfectly in all opengl modes
Cs creates tv3vvXXX files in C:, and their usually 40 kb
Cs usually works right after i format the pc

Turbo mode on (tried with turbo mode off, didn’t change a thing)
cas 2 latency

I think the problem has something to do with Counter-Strike and to some exctend my bad Ha
hardware combo (socket 7, tnt2).
I have tried a number of things to sort this problem, but none of them has made any
difference, such as:

Altering Bios settings
Using different drivers, including glsetup 3xx drivers. (Except that 10.80 “works”)
Innstalling Ali 1.68 agp driver
I didn’t find ant DVA=0 in my win.ini file, so nothing to do there.
I’ve formatted my sytem several times, but the problem keeps returning.
Copying opengl32.dll to my half-life folder

What I haven’t tried
1x AGP mode
Some of the creative drivers

Please help me, if I solve this problem now, I can finnaly rest in peace !

Half-life works but not Counter-strike? Strange…
Socket7 and AGP?
If the system works after you reinstalled is the hardware probably OK. Wrong BIOS settings usualy results in a locked system.

Yes, it’s strange.
I foud a even stranger “sollution” to my problem by runnig cs with gldirect’s drivers at max compability mode and then exiting cs and disabling gldirect.
To then run cs again, and it worked in OpenGL
(Not all the time).

But I got tired of this unstable crap and formated my system (again), and set my fsb down to 100 and all bios settings to default.

Amazingly cs seemes to work well now, and I’ve found that 5xx drivers gives me the best performance. I’ve set my fsb up to 105, and increased my multiplier, and it doesn’t seem to affect cs. I’m now running my k6-2 at 450@525 mhz, and I’ve even enabled turbo mode and my ram’s runnig at cas 2 latency

So I’m happy now, until cs’ll click again, wich it usually does after some time…