ColladaMax issues

I’m investigating using COLLADA in my company’s asset pipeline, to try and steer us away from proprietary technology. I’ve had a bit of play around with ColladaMax.

I’m aware from other posts that bipeds must export/import baked animations. I’m confident that I can post-process the data to remove unnecessary frames and data from that animation when I convert it to binary. However, what would happen if I were to export a biped to .DAE and then import it? Would I have to rig it with a skeleton again to modify the animations?

I’m also having trouble importing materials. The material names appear in the .DAE file but don’t seem to be imported at all! They don’t appear on the mesh, nor do they appear in the material list. Are there any known issues I should be aware of regarding materials?


About the export/import of bipeds. When re-imported: all the bones are converted into Max’s native bones, which are glorified transformation nodes. So, you should keep the .Max files around, so that the artists can easily modify the animation.

About the import of materials: What material types are you using? Right now, ColladaMax supports the export/import of the information for the standard material and the DirectX material. The materials, when re-imported, will not appear directly in the Material editor: you’ll need to import them from the scene (in the UI). I do remember that the material names were correctly imported, although they will be modified as spaces, ‘#’ and other characters are supported by ColladaMax.


That’ll do for now, until the support is greater. I’ll export from max to .dae and keep the max files, using COLLADA as an intermediate format before conversion to binary.

When animations from bipeds are sampled, is the interpolation between keyframes linear or on a curve? If they are linear, I can detect the sampled frames easily enough.

Yes, the sampled curve interpolations are always ‘LINEAR’.

You should note that in 3dsMax, you can create a linear interpolation controller. ColladaMax would export that controller’s curve with keyframes and the interpolations would also be ‘LINEAR’. I don’t know how likely that is for your application, though.

Is there a way to prevent the exporter from sampling the keyframes at specific intervals so that all the unneccessary keyframes are not generated? It would be nice if it could only the keyframes set by the artist.


Hi Matthias,

By default, the exporter will not sample the timeline to generate animation curves. You can activate this option manually by setting a sampling interval in the export options dialog. Alternatively, there are some 3dsMax features that are too complex to expose in COLLADA, so we have to generate sampled animation curves: biped/IK…