clinfo on Ubuntu 11.04 only recognizing 1 of 3 ati 6950 gpus

My goal is to have opencl setup on my computer for research work and be able to use 3 gpus and a cpu for computing. Is there something I am missing regarding setting up opencl on ubuntu 11.04 to have my system recognize multiple gpus. (3 x HD6950).

My installation steps were as follows from a fresh install:

  1. Download and install catalyst 12.6. I followed the installation instructions provided by amd for installing on a linux system then used command “sudo aticonfig -f --initial --adapter=all”.
  2. Download and install AMD-APP-SDK-v2.7.

Using the command clinfo only recognizes my cpu and 1 of 3 gpus. Is there another step that I am missing, such as setting up xorg.conf? If so then what am I missing and how would I go about fixing it?

I’ve had problems in the past due to the fact that the AMD drivers require an X session to be running on the chosen device. It essentially meant we couldn’t use the GPU in headless mode. I imagine this might be a similar issue as you alude to.
Perhaps try and configure the GPUs to all have an X session in your xorg.conf? Though it is a waste and needs to be fixed.