bind_vertex_input & colladamaya

Hi Everyone

Im writing a collada loader nowdays. Im using maya08 to create test models. I tryied the multitexturing yesterday. I made a plane (pPlane1), i made a lambert material, i loaded 2 files & i made 2 uv sets. After i connected the files to the materials diffuse & ambient channel. After that i opened relationchip editor & i connected the first texture to default uvset1 & the secont texxture to uvset2.
Finnaly i made a render (it was great) & i exported the model using the nextgen colladamaya exporter (v:

I analysed the model, but i did not find the bind_vertex_input chunk. After that i made a try to switch the connection (texture1->uvset2 & texture2 -> uvset1) & i exported again.
It was no difference between to 2 files (except the time value), and of cource the bind_vertex_input was missing to…

Help me plz. How can i solve this problem? Is it an exporter mistake?

Thx CollerbladE

(Sorry for my bad english)

Anyone ?

Sounds like an exporter bug. Try using the current OpenCOLLADA v.1.1.0 release instead of the older beta.

Thx for the reply. But the situation is similar. There is a bind_material chunk, but it has no childs. This is the same result. I think this exporter is the same as the original colladamaya exporter, because the plugin-name is “COLLADAMaya”.
This time i tried using “layered texture” too, but the result was even worse.

How do u make a scene with multitexture with maya?

Thx CollerbladE

If you are using Windows, please try ColladaMaya 3.05C which you can find from the ColladaMaya OSS wiki page.

Meanwhile, please provide a link with a sample Maya file so that we can reproduce your situation.


WOW now it is working. Thx the tip marcus. This exporter works great. It is different from the others. And now i have bind_vertex_input chunk as well.

sebastian: I wrote in my first post how i created the file. There are no tricks, no any other jokes.
1 object (for example a plane) 1 material 2 texture & 2 uvset. This is all.

But now its working, so thx everybody, im very happy now.

Bye CollerbladE

My ftp isn’t operation now, so i upload the mb file there. But u can simply recreate my file too.