All games freeze at home

I have a Gforce4 4600 video card and a Pentium 4 2.2ghz processor. 512MB RAM crutial.

Ok, when I’m on any college network, all my games run with no problems. When I’m not on a network, after about 5-10 minutes, my games will freeze. No error comes up, the game just stops playing and I can’t move the mouse or access other programs. Ctrl+ALT+DEL doesnt work either. This isn’t just an online problem since single player games freeze at home but not in school as well.

I don’t think it’s a driver update problem because I update my drivers often, and this problem ONLY occurs at home when I’m not networked in.

It can’t be a temperature issue because the room is a lot hotter and the comp is in a much more restricted space in school, yet there is no problem there.

It can’t be a loose wire issue since I check all my plugs no matter where my computer is.

It is most likely not a virus because I have cable at home and I have constant virus protection at home and at home.

The only difference at all between my games running fin, and my games freezing up is the college network.

If anyone can tell me why this is, and how to fix this problem so I can play at home, it would be greatly appriciated. I’ve been having this problem for over a year. It’s been a problem in 2 different houses, and has worked fine on 2 different collge networks.

Someone please help, no one seems to understand what this problem is.

Your virus protection program might be freezing it? Some of those programs have weird firewall protection and all the junk… try turning off your virus stuff… see if that helps

I tried disabling my virus software, but no change occured.

The monitor is the same? May be it!

I also have crashes with openGL games, ever since i got GeforceFX 5600, i cannot play half-life in openGL and other games like SAVAGE crash after 5-10 minutes of playing, i have all the latest drivers, no virus software, and i have tried multiple monitors. I cannot figure out why my computer cannot handle openGL anymore.

I just happened to come across this while helping a friend fix something.

I probably won’t respond but I’ll throw in my 2 cents to see if it sheds any light upon your situation.

Check your IRQ’s, specifically for your vid card/NIC (network card). They may be causing a problem. That’s really all I can think of that would even cause that, or maybe a faulty NIC or VID card, that seems unlikely though seeing as they work… lol.

If you can, try using a different NIC, or, completely removing it altogether, also try using a different video card. ISOLATE! That’s right, isolate any hardware possibilities first, and when you get desperate enough rip your system down to bare bones what it needs to run type stuff. RAM CPU Motherboard Hard Drive Video card, thats it, oh, and CD Rom if the game requires a CD Rom to run. IF it persists, at least you know its probably a software problem, be sure to fiddle around a little too if you get that desperate, switch out every piece of hardware that you can.

I know this post is long but like I said, I’ll never be looking at it again hehe.
Hope this helped.