Anyone have problems with (for example a cube
-representing a building) with objects that are close to each other flickering between each other.
I have tried altering the depth test parameters and changed everything to doubles( back face culling is also enabled).

Thanks, T.J

What do you mean: objects are static in the scene and flickering without any motion, or flicker during their motion, in the intersections?
For the latter case, are you transforming vertices on your own, or using OGL matrix xform stage? (if this was the case, it could be a rounding-error problem)

z-fight is the problem.

you can:
-increase the bits of precision of the depth buffer.
-use opengl polygon offset.
-make your decal a bit more far away from its belonging surface.
-use depth test=GL_EQUAL when decaling

i prefer the last method, i found it working good when the decal polygon is the surface itself.
i set the decal texture image border to alpha=0 and use GL_CLAMP as parameter.

there are other ways to minimize this artifact, but i can’t recall them at the moment…