XP, Opengl & Halflife

Geforce2 GTS - 21.85 drivers.
I’ve recently installed WinXP and Halflife refuses to run in opengl anymore. I get the error message saying “The selected opengl mode is not supported by your graphics card”. I’m trying to run it in 1024x768 and it used to run just fine under Win98.
Can anyone help me with this?

Yeah, same problem so I need some help cos the game ain’t working correctly under DirectX. HELP!!!

I’ve just found and installed the 21.88 drivers and it still doesn’t work…

Got the new drivers. Works for me now.

Before you run off to play CS (or whatever your favourite flavour of HL is…) Can you let me know how similar your system is to mine?
Athlon 1.1Ghz
Geforce2 GTS
DX 8.1

I upgraded Win98SE to XP rather than do a fresh install so if your setup is like mine I may just go and do that before I try anything else as there may be old driver files getting in the way.

Ok it’s fixed now. Fresh install of WinXP and the 21.88 drivers did the trick.

I found that instead of reinstalling winXP you can get round this problem by copying the opengl32.dll from your c:\windows\system to your ./gldrv directory in the half life one.
Then add the following line to the drvmap.txt in the ./gldrv directory: gldrv/opengl32.dll Win XP Opengl

Then start halflife/cstrike and goto to your video options and select the new “Win XP Opengl” mini driver that has appeared. You should now be able to play as normal.

This also applies to other games like quake3, where replacing the exsisting opengl32.dll in the game directory fixes any problems.

Hope this helps…

Hmm… I’m having problems wiht opengl in w2k (should be the same as xp)…
Could someone please email me this opengl32.dll that comes with xp? I really need to try it out!!! (kman@webmail.co.za)

I’ve sent you that file KApMan, I thought I better stick a post up so that you don’t end up getting several copies from some other peeps…

Anyway I should also make a correction to my previous post in that the directory where the opengl32.dll file can be found is c:\windows\system32 and not c:\windows\system as stated, but you all knew that right P

well i seem to be having the same problems too with opengl and half life CS. i tried all the things that were posted here like copying the opengl32.dll to the gldrv folder and renaming it in the .txt file. however when i try to run in opengl it crashes the game and sometimes my computer and i don’t know what to do. any help is apprecitated. oh yeah, someone said to possibly update my opengl drivers but www.glsetup.com (the link on this page to update) isn’t working…anyone know of another place i can get the newest versions?

Originally posted by Hannibal73:
Got the new drivers. Works for me now.

Hey Hanibal can you help the rest of us out and let us know what system you are using what video card you have etc.

Originally posted by Franks & Beans:
Hey Hanibal can you help the rest of us out and let us know what system you are using what video card you have etc.

Ooh and most important…what drivers did you use, and where did you get them from?