X64 vulkan programs to arm platform

I developed my Vulkan program successfully on a x64 platform, but wish to run it on an ARM platform. It compiled successfully, but couldn’t run smoothly, showing messages similar to these below.

WARNING: radv is not a conformant Vulkan implementation, testing use only.
Loading scene from ./…/…/assets-processed/dining-room-v1-512x4x5/lightTextureModel.gltf
Vulkan-glTF-PBR: …/src/vulkan/runtime/vk_object.h:90: vk_object_base_assert_valid: Assertion `base == NULL || base->type == obj_type’ failed.
Aborted (core dumped)

May I have help from someone experienced?

Hmm, I’m not sure what you are hoping to hear or get help with given the information you’ve provided. Your application hits an assertion that you presumably put in to catch a programming error (at least that is what assertions are generally used for). You’ll have to debug the application to find out why the assertion fired, working backwards from its location.
Please take a look at the Forum Posting Guidelines they contain many valuable tips on how to ask questions and what information to include in order for others to be able to help.

Oh, sorry for the confusion. The file that showed an error is not actually a part of my project. I wasn’t able to find the line that fired the assertion too. It’s ok though, I ran on a x86+amd GPU platform alternatively, and the code ran without a gliche. Though the warning is still there. Does anyone know what the warning below is about? It appears when I ran it on linux in mobaxterm.

WARNING: radv is not a conformant Vulkan implementation, testing use only.

Thanks!

1 Like