Works on Sun, does not work on SGI


I have a wierd problem, i had written a code using textures and stencil buffers for a Sun machine. It worked great, no extentions nothing just teximage2d and all that stuff.

I recompiled it for the SGI and no errors were thrown, then when i ran it… the texture would just not show up!!!

Second, when i recompiled it on my mandrake and Savage4 card, the stencil buffer also would not work. I have no idea why this is happening…

Secondly even if i ran it on a sun machine and imported the display to an SGI i still faced the problem of the texture not being shown, though it is loaded.

Im sure it is a glx problem, could anyone let me know what exactly this is?

Thanks a lot,

General ideas (I’m not using X):

For the texture problem make sure the texture size does not exceed the GL_MAX_TEXTURE_SIZE (implementation specific, minimum 64 must be supported).

For the stencil problem make sure the chosen pixelformat has stencil bits.

I know Performer doesn’t like textures that don’t have power of 2 dimensions, so maybe it comes from sgi restrictions? you should try resizing your textures…

no idea for the stencil buffer.

have fun!


I have been trying to resize the texture… my texture is hardly 128 x 128 size… and im sure i tried 64x 64 that did not work either…i dont know why im having this problem, i retried writing a specific code for SGI in itself… and that did not recognise the texture either…

Any ideas?



email me some simple code which works on
Sun and not SGI. I will check it for you (and fix it!).


Don’t forget the textures. Ideally as simple
a sample as possible (don’t want to get into working up a large application, with too many lib dependencies etc …)


Rob, i sent the tar.gz file to your email id, check it out, i stripped te excess features but still importing display as well as running on an SGI does not work, i found one more problem, i have a Savage4 (poormans) card and when i tried to run it on my Linux box, this thing once again conked out, but new problem, the stencil buffer is not working…its crazy…compiles great but output sux…im lost.

Thanks for the help,