WinXP Cannot open OpenGL Subsystem

hey, I just got JKII(Jediknights II) and I can’t seem to get it to play. I get this problem. Do you know any solutions for it?

----- Client Initialization -----
----- Initializing Renderer ----

----- Client Initialization Complete -----
— Common Initialization Complete —
Working directory: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\System32\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using desktop display depth of 32
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 32, 24, 8 )
…35 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 32, 24, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…setting mode 3: 640 480 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

It says that because it refuses to run in software mode. You must install your video drivers.

Read the other messages on this group. Everyone says the same thing.

V-man

[QUOTE]Originally posted by V-man:
[b] You must install your video drivers.

Sorry but which video drivers?

Each video card has its own drivers and each driver for each video card is made for a specific OS.

the major manufacturers are www.nvidia.com <-- has a all-in-one driver www.ati.com www.matrox.com

They have drivers for each video chip and for each OS including XP, Linux, etc.

Go into control panel->system
and check out the name for your card. Maybe that will help.

V-man

See other Jedi Knight 2 posts