Why are my textures black?


I am drawing a lot of small bitmaps at a map. First I used glDrawPixel, but because it is faster I am trying to switch to textures.

The problem is that my textures are black now! Wierd, cause the transparent part is displayed correctly. And if I turn light on, I can see the content ot my textures.

But light has disturbing effects on my other drawings, so I don’t want to use light.

Can someone of you imaging what is going wrong here? Is there a special texture mode, I have to switch to?

Thanks a lot, Heiko

If you get black textures, it’s proabably because you use GL_MODULATE and a black (or atleast a very dark) color. Either set the color to white, or use GL_REPLACE in glTexEnv*() instead of GL_MODULATE.

Thanks for your help. I found out about the colour right after posting.

But the GL_REPLACE was a very usefull information! My book (superbible) doesn’t list this parameter in the glTexEnv description… grmpl…

thanks a lot!