What can cause incorrect (different) results?

I was coding in OpenCL for a while, and I often had pretty strange issues. Sometimes my GPU refused to run the kernel correctly, and in some cases only on the Oclgrind simulator worked fine. Right now my GPU doesn’t write value to buffer (pretty normal OpenCL behavior :upside_down_face:). So generally, what can cause issues like this?

Driver problems, typically. Please specify your device, driver version and operating system, maybe I can suggest something.

Well, I’m using MacBook Pro with AMD Radeon Pro 560 discrete GPU. The drivers are bundled with the macOS itself. I think there’s nothing I can do with it. Works fine with Intel CPU, but does not with AMD and Intel HD Graphics.

Apple deprecated OpenCL and OpenGL in 2018, and there’s nothing we can do with it. They developed an alternative - Metal, but it works only on macOS.

In this case I suggest to open a discussion on AMD community forums, they fix problems in drivers for current generations of their GPUs.

Also, have you tried Boot Camp?

Also, have you tried Boot Camp?

Nope.

Drivers are made by Apple directly, and AMD doesn’t have any relations to it.

Ah, too bad, I have no real experience with Mac’s and probably try to avoid them in future due to exactly this reason. Maybe Boot Camp can be your savior, as drivers there are from AMD, not Apple.