weird glsl error in Ati Cards


I’m tryng to figure out what is wrong with this.
Anwyays, the problem is that i have my code running ok on a nvidia 6800 with latest drivers, and it fails in a ati9800 also with latest drivers.
The code is a shader, responsible for shadowmapping, nothing special.

In the ati card, it runs ok in the first loops of the program(in debug mode) once i try to give some value to a variable inside the shader, i get a glError, glGetError reports me error 1286 and 1282.

1286 i believe is GL_INVALID_OPERATION, but i’m not doing anything fancy here, what could cause this error being trown ?
1282 i have no clue what it is, i can’t find any reference to it in the net.
Any clues on what i could do to try to fix this ?


have you tried to use omega driver? previously, long time ago im using the original ati driver (mine is 9600xt). facing problems with shader too…(which i can remember what). then i switch to omega. seems that my system and myself are more comfortable with omega.

I just tried it, same thing

hmmm… try glintercept… check the log file…


Run glintercept on your app (full debug or author standard profile) and report the log file here.

Well, i managed to figure it out, i wasn’t setting the texture stage in the shader, i was just setting them in the texture units before applying the shader, somehow nvidia allows this, but ati doens’t.