WebGL doesn't work for me !!!

hello everybody, I encounter a problem with the use of webgl. I downloaded minefield and I changed the settings on about: confing as on the website of Vladimir Vuki?evi? but it does not always work.
I’m stuck, I tried with all browsers but still the same error, even if I defined “osmesa.dll” the webgl is always off. I work under Windows XP 32
could you help me please ?

Hi there,

What kind of graphics hardware do you have?


mobile intel® GMA X3100

Aha – I guess you’re probably the same Phoenix as this one, then: http://learningwebgl.com/blog/?p=2266&cpage=1#comment-4584 :slight_smile:

Try the newest nightly builds, like this one for Windows 32 bit:

http://ftp.mozilla.org/pub/mozilla.org/ … taller.exe

Software rendering should work after enabling webgl.enabled_for_all_sites, not requiring any other steps.

@kguciek – have the built ANGLE in, then? I haven’t seen any announcements, but could easily have missed it.

I was talking about SOFTWARE rendering:

Don’t know if ANGLE works just yet.

I was talking about SOFTWARE rendering:

Don’t know if ANGLE works just yet.[/quote]

OK, sorry – not sure how I misread that. So have they built OSMesa into the installer?

I took a look at the code and couldn’t find it anywhere, but I tested it and it worked on both Win & Linux.

Interesting. Do you have an Intel or other non-OpenGL-compatible graphics card? I have the impression that it ignores the software rendering toggle if you have working OpenGL drivers; I certainly can’t persuade it to do software rendering on any of my machines.

I tested this on systems with Intel cards and software rendering worked, and on a Linux box with a Nvidia card the sw/hw switch worked all right - as I recall, there’s a chance I just forgot, will check later, as now I am out for a week or so, hang gliding :slight_smile:

That would be a problem. Most (if not all) Intel chipsets only support OpenGL 1.2. So if the system is refusing to go into software rendering because there is a “working OpenGL driver” then that’s a problem because you can run WebGL on top of OpenGL 1.2 because (aside from anything else) it doesn’t support shaders.

Your best chance of getting it working is to use Direct3D via ANGLE. However, I’ve found that this doesn’t work on the older Intel chipsets…despite them claiming to have DX9 support. They don’t run any of the DX9 applications I’ve written - so if they do run DX9, it’s in some really minimalistic way. I tried - and eventually gave up on, getting WebGL to run on my wife’s old Dell desktop that has a 3000-series Intel chip.

So I’m pretty sure that the Intel GMA X3100 won’t run WebGL in hardware at all…and if having an OpenGL 1.2 driver stops it from falling back on software rendering - you may be completely screwed with software rendering too.

My son’s Win7 EeePC netbook has a newer (but still pretty crappy) Intel chip - it runs WebGL in Direct3D/ANGLE using Chrome and gets poor-but-bearable frame rates on our fairly complex WebGL application so long as you keep the canvas size fairly small and don’t throw too much geometry at it. It doesn’t work with FireFox/Minefield - although I expect that to get fixed when Minefield starts using ANGLE.