Vulkan code samples crash

Hi there

I downloaded / cloned the code sample from GitHub and ran CMake for Visual Studio 2019. After that I rebuild the entire solution successfully and I also copied the assets.
For some reason “.\vulkan_samples.exe batch” keeps crashing.
Am I missing another step here.

Any help is appreciated

regards

Hannibal

Are you getting any log output that hints at the cause of the crash? If the log window is closed immediately, try outputting the messages to a log file:

.\vulkan_samples.exe sample batch --log-file batch.txt

This will create a batch.txt that you could attach here so we can check for errors.

.\vulkan_samples.exe sample batch --log-file batch.txt produces an error on the console:

[info] Logger initialized
[error] [framework\platform\parsers\CLI11.cpp:236] CLI11 Parse Error: [batch] The following arguments were not expected: batch.txt --log-file
[info] Run a specific sample
[info] Usage: vulkan_samples sample [OPTIONS] [sample_id]
[info]
[info]   Positionals:
[info]     sample_id                   ID of the sample to run
[info]
[info]   Options:
[info]     -h,--help                   Print this help message and exit
[info]
[info]
Press any key to continue

What is the sample_id of the example hello_triangle ?

vulkan_samples.exe --log-file log.txt sample hello_triangle produced a log file with content. The shaders were missing. I added them by copying \Vulkan-Samples\shaders to \Vulkan-Samples\build\windows\app\bin\release\AMD64 (the loaction path of vulkan_samples.exe).
Finally the sample did start and rendered the triangle but I still got the feeling I am doing something wrong here.
Isn’t there a way to simply start one of the samples from within Visual Studio ?

Selecting samples from Visual Studio is also done by specifying it’s id via command line arguments. I’ve been using Smart Command Line Arguments for easy command line argument passing.

Executing vulkan_samples from within Visual Studio with the proper command line arguments works fine.

Thank you very much :slight_smile: