Vive Cosmos Controllers not working some times

I don’t have additional information. The code doesn’t reakky differ throm the o,e ine Hello XR. We adapted the code to our OpenGL version and to our C++ version.

Hello !
Do you have some news for me ?

I tried to use multithreading in my VR sample to make a similar situation to the application I’m developping. Multithreading with SteamVR runtime works well in the sample so I don’t know why I have my problem in my app.

Sounds like a possible explanation could be that there is some call order of OpenXR functions that leads to a bug in the runtime triggering. With multiple threads calling API functions, there would be a bigger chance of a race condition for the bugged call order to happen.

I remember the SteamVR runtime having bugs with the call order before, but the known ones should already be fixed.

Hmm. The “multithreading” test in the CTS is basically a simple fuzzer for runtimes, so ideally there shouldn’t be too many uncaught issues there, but I don’t have a headset using this runtime to verify.

Could you report this issue on our Vive Forum - OpenXR? (You may just google for it since I cannot paste any website here)
We can directly communicate and provide information from both side on that forum.
I will get back here when we address this issue.

Hi ! Thanks you for your answer. I reported the issue on the Vive Forum.

I’m using Steam VR. Don’t you use Steam VR ?

I test with a large number of runtimes on a regular basis, including steamvr, but there are differences between the different drivers.

I checked my session state and I have a message :
Failed to load binding file. We’ll wait and try again when CRC or load count changes( computed CRC=0, old CRC=0, shared CRC=0, load count=3, shared load count=5

Is there no way to force binding ?

That looks like it could be output from SteamVR. If you go into the SteamVR binding menu when that error happens and the application is still running, does the application have a binding selected? It should have the Current Binding set to something like “Bindings from OpenXR” if it is using the suggested bindings from the application.

Sorry for the delay but my controllers worked well for few times. They are not longer working so I checked the binding settings in OpenXR. You are right.

That looks like it should be binding them correctly then. You can also look in the SteamVR binding editor to see if all the actions and bindings are in there.

I don’t think it’s a binding problem. When the controllers works, the binding works well. It’s just that sometime, the controllers are not detected by my headset and I would like to know why.

Still nothing since I submitted on the Vive forum.