Viper V770 non-ultra and OpenGL

I am having problems with opengl and my viper V770 non ultra graphics board.
Whenever I run Quake3/milkshape/half-life in opengl (not in direct3d) my images just freeze and I have to reset my pc. I have got all the latest drivers.
my configuration is:
-Viper V770 non-ultra
-AMD K6-2 450 on Aopen AX59 pro motherboard (via mvp3 chipset)
-soundblaster 128
-2 nic’s

Please help me, i am getting desperate

Mail if you have comments or a solution.

Is the card getting enough power?
THere is a problem with some mother boards to supplying enough power to the agp slot (well teh supply the right ammount just the card wants more more more ), or maybe the power supply in your comp is to slow.


The problem has something to do with the TNT2 chipset as my system crashes when I run Milkshake but I am using the reference drivers from the chipset manufactures.

Also try using an earlier version of Milkshape as my earlier version worked fine

[This message has been edited by Tall man (edited 07-12-2000).]