VGA output under opengl

Hi all.

I have noticed that if I have the windows desktop connect my computer to a projector with a VGA cable and turn on the project the projector is going to find the edges of my screen and not crop/overscan at all. If I start an OpenGL app is keeps these settings and my full screen is visible.

However if I turn of the projector and turn it on again while still in opengl mode it overscans / crops. I would assume that this has something to do with how opengl works with HSYNC and VSYNC. Does anyone have a clue on how to fix this problem. And no, DVI is not an option and the projector is not high-end so I can lock the VGA sync.


This problem has nothing to do with OpenGL. When the projector is switched on it will ‘analyse’ the incoming video to try to determine where the active portion of the video is. If the incoming video information is black around the edges it does a poor job of it.

Bacically you either need to switch off the ‘automatic source detection’ in the projector (if possible) or switch it on when it can see a full video frame (like the desktop).

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.