VBO - Remote Display fails

I’m having trouble displaying VBOs via a remote display and I get errors such as this:
Error: no OpenGL buffer object appears to be bound to target 0x8892

When running a VBO demo remotely, that I found on this site: http://www.songho.ca/opengl/gl_vbo.html I get the following error:
GL_ARB_Vertex_buffer_object not supported

I’m not sure they are related but I think they might be…simply because both are VBO errors.

Just to clarify, when I run my code (JOGL version) on a local machine it works perfectly fine - VBOs display, etc, yay. When I ‘ssh -X’ to a remote machine and try to display the program on my local machine it fails with the first error. Similarly, the C demo code does the same thing, but the error is different…ie it works locally, but fails remotely.

In all cases the local and remote machines are RHEL4 32 bit machines with the exact same hardware and I’m using KDE for the desktop.

Mind you, if I use immediate mode for rendering then it works fine…my program works fine. The example C code (2nd link above) also works with VBO off and you’ll see that in the top left corner of the program when it runs: “VBO: off” and you can’t toggle to “VBO: on” via the SPACE key because of the initial error prevents it.

I’ve started this same topic/thread on the JOGL forums thinking it was a JOGL issue, but it seems it is a general OpenGL issue or an issue with my drivers. I’d be surprised it is a driver issue since the local display works fine so I’m not sure what the solution is.

Here is the link to the JOGL forum thread for reference:

Here is a link to someone else’s thread on the nVidia forums where they had the exact same problem but there does not appear to be a solution:

Does anyone know of a solution? The workaround is obviously not to use VBOs but that results in lower/slower performance so it is not desirable. Thanks.

FYI, I moved this thread from the “Beginners” forum…sorry for the duplication.

See this thread, same problem, and it seem VirtualGL solved it :

By the way I found this by searching “remote” in the forum :stuck_out_tongue:

THanks…I initially searched by the error that I got and didn’t think to search by my own thread title…sorry, but thanks.

btw, what are the odds that the same obscure problem I’m having someone is having at the same time…just uncanny how those things happen. I can understand if this was a common issue, but I think this is pretty obscure and does not affect that many people. Anyway, thanks a second time.