Various things

Hi,

I have a few problems and I would like to ask you to confirm a few things:

  1. It seems that once again I ran out of varying floats (60 in my case). However, neither Shader Designer where I usually test my shaders nor the compiler in my application warned me of this. The shader simply did not work it even seemed to freeze. A few times I even got the dreaded BSOD.

I spent days trying to find out what was wrong and only after I commented out two of my varyings did everything get back to normal.

Is this ‘normal’ that there is nothing to warn me about having more varyings (with the built ins, of course!) that the hardware can handle?

  1. I even tried to install the latest nvidia driver because I thought it might be a bug in the driver. Of course it did not help with the varying issue, but Shader Designer stopped working. It does not even start. Rendermonkey, which is the other shader IDE I use from time to time still works, but if a shader can be tested in Shader Designer, I prefer it for its simplicity.

Did anyone try the latest nvidia driver with Shader Designer? Can you confirm if it works or not?

Thanks.

  1. Normally (for me anyway) I get that information when I query the information from the shader after compiling and linking… (glGetObjectParameterivARB) Are you saying that you did not get that info back?

  2. No idea I am afraid.

Are you using XP or Vista? Can you tell me your OS, graphic card and driver version? I’ll try to reproduce the problem, but I dont promise a fix in the Shader Designer (I had to stop supporting it some time ago)

Hi,

Thanks for your response.

Shader Designer: 1.5.9.4
Nvidia driver 182.08

GPU is GTX260

OS is XP SP2.

Shader Designer is working with driver 178.24 (the one I used previously).

Thanks.

As I suspected, the problem is caused by a incorrect opengl version string handling by GLEW. If I can, I’ll rebuild the application with a newer GLEW version (and this time, as dll, to avoid this kind of problems in the future)

I’ll comunicate this when I’ll finish.

P.D: In the meanwhile, I suggest you to use an older driver.

Regards,
Jacobo.

OK, thanks very much. I appreciate it.

I’ve uploaded a new version with the fix (www.typhoonlabs.com). Tell me if you have any problem about.

Edit: By the way, now that I have the project ready to compile, I could program into, some features, so suggestions are welcome :slight_smile:

Unfortunately, this does not work. This is not a setup, so I guessed I should just copy the files over the old ones.

I get an error message that the application has failed to start because the configuration is incorrect. Reinstalling the application may fix this problem.

Tomorrow i’ll check further. Meanwhile try with the new package standalone (execute it directly after uncompress)

That produces the same error message.

Install the vstudio 2008 redistributable package: http://www.microsoft.com/downloads/detai…&displaylang=en

Thanks, that was it. It works now.

Since you wrote that you are open to suggestions about improvements for Shader Designer, here is my list:

  1. Find/Replace in the editor.
  2. Switching between fragment and vertex shaders, the editing window always displays the text from the top, and not at the position you left it the last time. This is wrong and very annoying.
  3. Splitting the editing window is nice, but the same problem as 2. applies here too.
  4. Widgets could be smaller and the user should be able to decide if he wants them to always stay on top (preferences?).
  5. Other texture types with arbitrary size would be nice.
  6. Multiple pass, with multiple shaders. It would be a huge improvement. I could write and test shaders with reflections, shadow maps, etc.

This is off the top of my head. If you are willing, I am sure I can think of a lot of other things as well :slight_smile:

Thanks a lot once again.

Hi,

There is still something wrong with the new version. If I open a widget, it crashes. Could you do something with it?

Thanks.

Its now fixed