VAR memory allocation

I can’t get wglAllocateMemoryNV to return anything other than NULL. I tried sizes all the way down to 32 bytes, I’ve tried all sorts of different combinations of read/write frequencies and priorities, nothing seems to work.

I’ve even tried running other peoples’ code, and they all fail as well. I know my gf2 supports VAR, so what could be happening?

Maybe a problem with your motherboard drivers …

There’s a small tool on nvidia web site that display the available AGP memory. you should try it.

try also using video memory.

Well according to this app, I have 128 megs available, and 128 megs free. I’m gonna try turning that down to 64 megs and see if it makes a difference.


My bios said that I had 64 megs allocated. I changed that to 128 for no real reason. I rebooted and ran the nvidia app again, and it still says i have 128 megs. I’m going to see about any motherboard driver updates I can find.

Thanks Again!

so it turns out that after formatting I forgot to install the via 4-in-1 driver pack that i’ve always been using. Thanks for the help.
However, although I am now getting a valid return from the wglAllocateMemoryNV call, I’m afraid to use it. I was just debugging, and set a breakpoint right after that call, and my whole system froze up, I couldn’t even ctrl-alt-del to get to my task manager. At least winamp played on like a champ. I’m gonna give this a few more tries, and if I can’t figure it out I’m sure I’ll be back here again shortly.

Thanks Again!

I can’t thank you enough for the difference your advice ended up making. Now that i’ve got my var’s working, i’ve jumped from 1.6 Mtri’s per second to 10.2 Mtri’s per second. I’ve got 166,000 tri’s per frame and i’m getting over 60 fps!

Thank You Thank You Thank You!


The upgrade from Windows 98 or ME to Windows XP Home Edition is well worth the $99 if you’re doing development. The sooner you can get away from 16-bit Windows, the better (and once you do, you’ll kick yourself asking why you didn’t sooner).