Unstable nvidia drivers... anyone else having trouble?

hmm… the nvidia’s drivers off the site, are VERY unstable under my system… I have NO clue what could be wrong, X just hangs when trying to do OpenGL stuff. 25% of the time an app tries to do OpenGL stuff it takes out X and the keyboard. Anyone else having the same problem?

I am using RH7.1, and followed all the directions in the README file. I am using a Viper 770D Ultra with 32 megs of RAM.

It’s annoying not to be able to use acceleration under linux .

I m using nVidia drivers since november 1999
(Riva TNT2, GeForce2 )and everything works fine.
The problems you are describing looks like
a wrong installation, not driver problems…

be more specific if you want some help…


Sure… I can be more specific. What do you mean when you say by wrong installation? That I might’ve overlooked something?? It’s possible… what should I do next?? Unfortunately, I am away from my box right now (wedding), and won’t be back till monday. What kinda of specifics would you like me to look into?

Have to tried running “gears”? I have problems with the nvidia driver too, but only with programs that use OpenGL in full screen. Try this to see if your problem is the same as mine:

  1. Reboot your system into X (for a clean boot).
  2. Run “gears”. If it seg faults then you probably have installation trouble.
  3. If it runs, try running another openGL program but in window mode. I used “gltron -i” and it worked.
  4. if it worked, then run gltron or some other openGL program full screen.
  5. If that worked you are doing better than me and I am screwed!!!

For trouble with installation:
Download the tar files instead of the rpms. I had better results that way.

Let me know what you find. By the way, I have reinstalled my mandrake 8.0 many times trying to get this problem solved until I got stuck.


  1. what chipset are you using (not the name
    of the gfx card, the chipset is important).

installation of nVidia drivers is in detail
described at their linux driver page, but basically there are

  1. make and install Nvidia kernel module
  2. install nVidia gl libraries
  3. modify XF86Config file

startx and enjoy !

go to www.nvidia.com
Linux driver download page, read Readme
and FAQ files.

if you will get problems ask (copy&paste the
error msg.) or desribe what exactly is not working…

at the begining you should try some OpenGL
program (demo/game) without any dependencies
on libGLU or libglut…
just a pure libgl application (like quake )…


I did get correct installation going and have acceleration and all that stuff. But for some reason X locks up when netscape runs. I am on a 1.0ghz amd athlon, GeForce 2 Mx with 32 megs. Im using RH 7.1 . Whta is “gears”.

Gears is a little program that runs opengl showing a few gears moving. It is a good demo to see if your system can handle OpenGL.
I finally found the solution to my problem with the nvidia drivers. I could run OpenGL games in window mode but not full screen. I got the tar files for the drivers and compiled them (not that you need to install the kernel source code to be able to compile the kernel section of the drivers). I also added the extmod to XFree
Load “extmod”
and erase the other section in Modules that says bout extmod

Programs can now run full screen as long as I am using the same resolution as X.

Try compiling your own driver, it works better.

  1. Use your package manager and install the kernel source. There is normally a way to search for the packages, but the name is here
    or so (this is for mandrake). Use your package manager so the other dependencies get installed.
  2. Untar the nvidia driver packages.
  3. Follow the instructions on the website.
  4. Remove the section in Modules that says:
    Subsection “extmod”
    something here
    and here
    Load “extmod”
  5. restart the X server (reboot perhaps).
  6. try gears, then chromiun, then gltron -i.

Did it work?

I’ll try when I get back… (sunday). My problem isn’t with fullscreen and stuff… its about freezing… X freezes 25% of the time when a GL app runs. . No errors (even in the /var/log/XFree86.0.log file), nada… just plain freezes.

Btw, should I be touching Mesa at all after I install the drivers?? I wasn’t doing it before.

Thanks for trying to help me . I’ll see what happens.

The problem with redhat 7.2 is that it includes a beta in-dev version of gcc, and that almost everything has been compiled with it.

So, to stick to a “up to date” image, it just istn’t that useable.

The NVidia drivers works very well with most other linux distibs.

Last week , I install nv driver for my box,and there is no problem when I run my test.(my test is all of the tutorial’s demo code on http://nehe.gamedev.net/ )
My configure is Rh7.1 , TNT2MX 32M , BX board, P3*2.
I download 2.4.6 kernel and selected the DRI support in kernel configuration , then ,I download nv driver source code , follow the guide in the readme file ,compile and install it . Finally follow the guide , I do some setting for xfree86 .haha ! every thing is OK!

mailto: zhongcheng@china-channel.com

Okay, this is what I did

Compiled a kernel 2.4.6
installed nvidia_kernel
installed nvidia_glx
(by source)
fixed up the XF86Config-4 file
used the nv_check.sh to see if everything was working fine… (it checked out ok)
but, it’s still freezing!!

my XFree86.0.log is up at www.imsa.edu/~ngill/XFree86.0.log…
you can view that nicely in lynx .

yah, any help would be appreciated! Since, it sux rebooting every 5 mins .


You can also put up your XF86Config-4 file.

I did that

anything else?

oh btw, I added Option “NvAgp” “2” or something in my XF86Config file… it fixed up my AGP problems… which caused most of the problems! . But it still freezes time from time.

I just looked at your config file and it certainly looks a lot different than mine. Here is some comments and suggestions:

  • The ‘Option “NvAgp” “2”’ should be in the device section above for the diamond. You should probably try to set it to 0 instead of 2.
  • I think that the “Diamond device” section should have a BusID line. From the nvidia sample
    Section “Device”
    Identifier “NV AGP”
    VendorName “nvidia”
    Driver “nvidia”

    update this with the PCI id of your card. Consult the output

    of the ‘lspci’ command.

    BusID “PCI:1:0:0”
  • You should have the sample and other documentation at /usr/share/doc/NVIDIA_GLX-1.0/

the NvAgp option was set to 2, and AGP started working after that… so, I think I’ll leave that alone for now, unless you have a better reason.

I’ll try the other suggestion

No, AGP is not working. You are setting it to AGPGART but you do not have that installed. You can of course install it and try. Here is another section from the nvidia documentation
Option “NvAGP” “integer”
Configure AGP support. Integer argument can be one of:
0 : disable agp
1 : use NVIDIA’s internal AGP support, if possible
2 : use AGPGART, if possible
3 : use any agp support (try AGPGART, then NVIDIA’s AGP)
Default: 1.

the system seems less stable now, and screen artifacts (like parts of windows are still there after I move/close them) are back. . I think I am gonna switch make to Nvagp 2.

How can I install agpgart?

I installed AGPART once but do not remember how.
Search the net for the information.

If parts of a window is not deleted after you close them does it sounds like you have not installed X correct.

okay, AGPGART seems to be working… I compiled it in the kernel with support for my Ali board.

X is installed correctly! No more screen artifacts… as long as I use AGPgart… I heard that nvidia doesn’t support my mobo all the way, that might be a slight problem. It’s kinda stable now… in 2D i suspect it might last for days. In 3D however, only a couple of hours. not too shabby, but could be better.