Tried to setup opencl in VS15 but initial compile is failing

I started very basic steps from OPenGL site below:

and did everything exactly except I bypassed compiling of the opengl source and instead downloaded and used precompiled glfw binary and pointed all necessary directories:
include / lib in C++ directories
lib in linker from VS15 community version.

Lastly, generated glad from https://glad.dav1d.de/ and added the glad.c to the source file.
Now the tutorial states I should be able to build but instead I got following error:

Hitting the compile button shouldn’t give you any errors, at which point we’re set to go for the next chapter where we’ll discuss how we can actually use GLFW and GLAD to configure an OpenGL context and spawn a window. Be sure to check that all your include and library directories are correct and that the library names in the linker settings match the corresponding libraries.

Severity	Code	Description	Project	File	Line	Suppression State
Error	LNK1104	cannot open file 'C:\git.co\glfw\glfw-3.3.2.bin.WIN64\glfw-3.3.2.bin.WIN64\lib-vc2015.obj'	project1	C:\git.co\dev-learn\opengl\project1\project1\LINK	1	

I am wondering what I am missing???

I uploaded the VS15 project here

but it assumes the include glfw directories are as follows:

C:\git.co\glfw\glfw-3.3.2.bin.WIN64\glfw-3.3.2.bin.WIN64\include
C:\git.co\glfw\glfw-3.3.2.bin.WIN64\glfw-3.3.2.bin.WIN64\lib-vc2015

However I dont see anywhere, searching from glfw root directoires that there is a lib-vc2015.obj file which VS15 complaining about…

Check the configuration, specifically Linker -> Input -> Additional Dependencies. For some reason, it’s treating the library directory as a library name.

That link doesn’t work; I suspect that the repository isn’t public.

Ok sorry, looks like it is set as private, not sure how to setup as public. I have uploaded the project code into following:


I will look into the add’l dependencies, although I thought I did everything right.