Tribes 2 won't boot up!

Well, I just got tribes 2 and after installing it it won’t boot up!

I double click on the shortcut and it the screen goes black like every other game except then it just stay’s black.

I have to press crtl-alt-del, then end task, it says tribes 2 is not responding.


I’ve got a p3 866, 128mb ram, gforce 2 mx, directx 8.0a(have to have this to run tribes 2) and the 11.01 drivers,

oh, and on the disc there is a opengl setup install thingy and when i click on that it says my opengl drivers r not up to date,

Could that b wats causing the problem?

If not, pls, can u help me on y tribes 2 is not booting up, i’ve tried a reinstall of tribes 2 but still the same thing.


Your best bet is to call the sierra support phone number in your game manual.
Dont do the automated help, select to talk to a rep. (The wait is longer but they helped me with some patch problems I was having.)
Good Luck,

PS. MAN you are gonna love this game when u get it running.

I have the same problem.
Hope this helps you out.

Bug description: Unhandled exception c0000005 at address 02b7c118

TRIBES2 caused an invalid page fault in module OPENGL2D3D.DLL at 0177:02b7c118. Registers: EAX=00a28558 CS=0177 EIP=02b7c118 EFLGS=00010202 EBX=00a2a340 SS=017f ESP=00c2d3f8 EBP=00c2d558 ECX=00000000 DS=017f ESI=00000551 FS=1377 EDX=00a28570 ES=017f EDI=00c2d40c GS=0000 Bytes at CS:EIP: a5 a5 a5 a5 8d 73 0c 8d bd d4 fe ff ff a5 a5 a5 Stack dump: ffffffff 00a28eb0 00c2d7b8 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

GraphicsCard: Radeon VE 32meg DDR 1 processor type 586. AMD Athalon 1GIG 256 MBytes physical memory PC133. Nothing running in the back ground

I have loaded most recent Via chipset drivers.

I’ve have the most current ATI Drivers

Tried to update newer version of OpenGL but was told it doesn’t supprt card

This is the reply from the sierra support forum.
Post here if it works for you.

First, make sure that you have the latest recommended Radeon VE drivers installed from (NOTE: Your dual monitor setup will need to be disabled for Tribes2) Now do a Search or Find (Depends on Windows version) for OPENGL2D3D.DLL on the drive that Tribes2 is installed to. Now rename the OPENGL2D3D.DLL file that was found in the Tribes2 folder to OPENGL2D3D.OLD, and then run the web based GLSETUP at If asked to, FORCE the GLSETUP update. It may take 2 or 5 tries, because for some reason the Radeon VE’s don’t want to update easily. (My 32 DDR Radeon ran it just fine) Once the GLSETUP has updated your OpenGl drivers, it’s Tribes2 fragfest time baby.


PS. I have personally seen this work for 3 different Radeon VE’s, so keep running the GLSETUP till it works.