Transparent window possible with integrated graphics only

#1

I have been following the vulkan tutorial for a while now and just got to the part where I was able to create a triangle.
I wanted to get transparency working because it’s a major part of my project.

I made the clear color alpha value 0.0, and started experimenting.
I spent some time bashing my head against the wall, because the validation layers kept telling me that these alpha compositing(?) flags were not supported, so I went as far as to create the windows myself (instead of with glfw, which is what I was doing).

Some time later, I noticed that the support for the flags is there, but only for my integrated graphics card:
image

So when using the 1050 I get the black:

But when using integrated graphics:

boom works

This was even a bit weird to me because it was working even though I was still setting the compositeAlpha to VK_COMPOSITE_ALPHA_OPAQUE_BIT_KHR . Looks like windows does the alpha blending without the need for the flags.
I did then experiment with changing it to the POST and PRE flags, but saw no difference at all.

I’m new to this so I’m at a loss as to how things may work.
One more thing is, my windows advanced display settings shows this:
Image

And so I thought that maybe, as it’s the integrated graphics that’s doing the rendering of what seems to be the windows system (I’m assuming that’s what “display 1” entails), it is the only adapter that has access to those framebuffers and is thus the only that’s capable of doing the blending.

Am I right? Because if I am, then I must find a way to display with the driver that’s doing the windows rendering, and render with the most powerful one, since it seems that windows often picks integrated graphics for it’s display stuff.

And if I’m not, I’d be really glad for you to explain to me why I’m dumb :smiley:

Thank you.