Transparency problem


I have 2 textured planes (tga texture with alpha) in the same position and I can only see one plane it’s the last one I render

I have activated blending like this :


How do I solve this ?

Thanks a lot :slight_smile:

glDisable( GL_DEPTH_TEST );

Most likely your first plane is setting depth, and your next plane is reading/testing against depth and being occlusion-tested away.

Ok thanks.

And How can I do to keep the native color of the first plane and the native color of the second ?
Because right now I get a mix of the colors and it is much more darker than the natives colors.

I set the blending like that:


What do you mean? You’re blending. So presumably your goal is to get a mix of the two colors, right? Otherwise just disable blending.

You might describe in more detail the exact effect you want to get (all aspects of it) and why.