TNT2 32Meg M64 problems with OpenGL

I originally had this card intstalled and Counterstrike ran perfectly in OpenGL 800x600. After a few months, the card stopped working. So, the store I bought it from exchanged it. Now, Counterstrike keeps giving me the message “The selected OpenGL mode is not supported by your video card.”
I have no clue as to why I get this error message. I have the Detonator 3 version 7.17. Any suggestions are appreciated.

I also have the same problem, I got TNT2 PRO 32MB. I ran CounterStrike before smoothly but then just recently it went distorted and hunged my PC while CS is loading. I don’t know what’s the problem though but NVmax somehow helped my system to get OpenGl works with CS again. By the way, do you got AMDK6-2 as processor and VIAchipset board? well somehow it has something to do with the problem.

I have a 433 CELERON with 96 megs SDRAM.
I don’t know the chipset though.

I tried NVmax and my card still doesn’t work with CS. What settings did you use in NVmax?


A typical DVA problem.
Run your Win.Ini and search for a line called DVA. If you got this line give me a reply or look in other posts in this forum.

I found the DVA line. What should I do? Erase it?

Well Lucky you!

Add a semicolon ( before the DVA (The line should now look like this: “;DVA=0” (without quotes))
Save and close the file
If you find this causes more problems, just take out the semicolon.

I have a CL video board w/ TNT2 Nvidia with VIA chipset on a Tyan Trinity 400 board. The DVA solution worked like a charm! Everything went screwy when I installed new VIA chipset drivers and then no opengl games worked. Curse those hardware designers!

When you install the Via 4-1 drivers is real important you doesnt choose turbo mode.
The openGL seems to only work in 1x agp as well.

I tired with the semicolon and without the seicolon. It still won’t allow me to play in OpenGL.

Weird it should work. Add the semicolon and save it. Close the win.ini.
Run the win.ini once more to really see
that it have been saved with semicolon.
Be aware of that you could have more DVA lines in win.ini . You have to search all and make the changes.

Give a reply about how it work out!


I searched the win.ini file and found only one DVA line. I added the semicolon and CS still won’t work.


First do a test to other OpenGL applications
games(quake,sof,alice), screensavers or whatever to see if isnt CS that failure.

If the problem occur in every OpenGL apps.
do a reinstall of gl setup and remember to force the install if you been prompted.

I believe your real problem was the DVA line but things been messsed up when you not get it going.

Your config should work thats for sure.

Give a reply

[QUOTE]Originally posted by devideman:
[b]I searched the win.ini file and found only one DVA line. I added the semicolon and CS still won’t work.

ok that guy got it wrong…you put the semi colon AFTER the DVA!!!
DO IT NOW!!!mine done exactly the same,then i did this and it worked

I placed the semicolon after the DVA and it still doesn’t work.

I tried to play Soldier of FOrtune, but I keep getting an illigal operation error stating that it can’t open the openGL file.

I tried playing CS on my cousin’s computer with a Voodoo 5 5500 card, and I still can’t play in OpenGL mode.

I tried playing Soldier of Fortune and Quake 3, but I keep getting an illegal operation message that says there’s an error opening my nvopengl.dll file

You have to do a clean uninstall of your graphic drivers.
First uninstall the openGL. To uninstall the graphic drivers you have to do as follow
Open display properties-settings-avanced-card-change- and choose standard vga, then restart the computer. Then you have to restart it once again. Now you can install the drivers that follow the card (remember not to install detonators).

You have to try it!

ps!! Geforce says add the semicolon before DVA but I guess it doesnt matter the purpose is to disable it one way or another.

Moi jviens davoir une RIVA TNT2 M64 32MB AGP pis ca buzz en criss avec UNREAL TOURNAMENT… je sais ben que ca marche juste avec DIRECTX parske OPENGL c’est dla marde… entk J’ai DIRECTX 8.0 pis c’est fou en criss! si ya quelqun qui sait pkoi ca plante stp repond au plus caliss… jai un PENTIUM 2MMX avec 128MB de SDRAM…

i have a tnt 2 m64 also and counterstrike was giving me the same message…i copied opengl32.dll and nvopengl.dll found in your windows\system directory into the sierra\half-life\ directpory and it worked perfectly fine.