The Radeon Disappointment

I have friends who have Radeons. My second
OS (BeOS) is supposedly beta testing Radeon
GL drivers. And I’m selling my RT2000 video
editing suite, which means the requirement
for a Matrox G400 goes away. What better time
to get a Radeon All-in-Wonder 32MB DDR?


First, I tried getting it mail order. Most
places, it was out of stock, but
was showing it as available. They even sent
an acknowledgement e-mail. However, the card
is now out of stock at their place, and my
order is “on hold in the warehouse”. So I
went out and picked one up at the local
electronics store.

Ripping out my old card, de-installing the
drivers, sticking in the Radeon, letting
Windows install the VGA drivers. Load the
drivers and tools from the supplied CD. So
far, so good. Screen looks nice, too.

Trying to start a game.


Oh, joy. A compatibility issue! This game has
just been patched, and has been mumbling
about new DirectX issues in the release
notes, so I three-finger salute my machine
and get back to the desktop. Okay, let’s try
DXDiag. Press the Test Direct3D button.


Not good.

Okay, I fire up my current OpenGL project.

“Initialization failed.”

Hey, I do more error checking that those
choads down in San Diego! :stuck_out_tongue: Or maybe just
DirectX doesn’t give enough error info back.

Okay, let’s go to the ATI web site and look
for drivers. Look! there’s a line of people
who have issues with “seeing a black screen.”
Sounds like me. I’ll download the newer
version of the driver, from the “tested and
recommended section”.

Download. Unpack. Run. Reboot.


Wait! I didn’t even try to start a game yet!
Umm… how am I supposed to back out of this?

I re-start in safe mode, and try to run the
ATI Display Driver uninstall program. Too bad
Safe Mode won’t let you run installers or
Okay, so I remove the Radeon entry in Display
properties and re-boot.

“PCI VGA device detected” – yeah, I know.
I want 16 color graphics in 640x480 so I can
surf on over and get the latest beta drivers,
curiously prominent on the Radeon support
web site.

“Ah, this is a Radeon! Please insert the ATI
Radeon Install Disk.” – Damn those new-
fangled WDM INF files that actually makes
Windows recognize devices after you uninstall
them. Okay, I put in the CD.

“The CD was not found; please insert the
correct CD.”

After a little searching, I realize that the
INF file they installed must have been for
some other CD, as my CD doesn’t have the name
(nor path) that the machine is asking me for.
OK, so I Cancel this file.
And the next.
And the next.

for (i=0; i<254; i++)
puts(“And the next.”);

It appears that they’re shipping one version
of each file for each language recognized by
the United Nations, and a few extra dialects
of Swahili for good measure. I may have a
case against ATI for repetetive streass
injury here.

Anyway, I got through all that, and the
machine happily reboots, not having actually
installed anything. Windows logo… loading…



I re-boot into “Safe Mode with Network
Support” to go online and download the next
version of the driver, an “unsupported” beta
which curiously was prominently featured on
their Radeon support page.


“Safe Mode with Network Support” does not,
actually, let you use the network, because
it will still disable your network adapter.
Silly me.I should have known better than to

Thinking hard, I remember I have an ancient
PCI Rage Pro in a closet. Ripping out the
Radeon, and sticking that card in, I again
have a working desktop, only two reboots

Okay, on to the web, download beta drivers,
unpack, and install.

“This machine appears to be incompatible with
this version of the ATI drivers.”

Umm… yeah…

Okay, try running the ATI Display Driver
uninstaller again, which didn’t work in safe

“Unable to uninstall unknown or older version
of ATI drivers.”

I’m trembling by now. “I don’t want you to
uninstall my current display driver, I want
you to uninstall the display driver you
installed in the first place, you dumb piece
of code!” Did I say that out loud? Looking
around, I see I haven’t woken up my wife.
Gotta concentrate.

Okay, what if I remove the Radeon, and let
the INF auto-detector point at the unzipped
updated driver, rather than the CD that it
can’t find? Worth a shot.

Oh, no. That file doesn’t actually exist with
that name in the unzipped driver install.
It’s probably part of some .CAB or .___ or
God knows what else. Now I have to press the
cancel button 257 times again.


Yeah, well, what do you expect? Still the
same driver, of course I get the same result.

So I bring out the heavy artillery. I delete
every file named “ati*.*” from my windows
system folders (inf, system, drivers,
system32, you name it). “Hah!,” I think
loudly to myself. “Take that!”

Indeed, I do get a reboot which goes into
16-color mode. Only to display the “Please
insert the ATI Radeon Install Disk” alert.

What!? I nuked your INF files! I neutered
you! Why do you keep coming back!?


Luckily, I paid for this card with VISA.
After sucking up four hours of my life, it
is going back to the store tomorrow morning.

Now, what do I do? My favourite OS will not
have GeForce GL drivers, according to
reliable rumors. And while it will have
Voodoo drivers, those do not support HT&L,
and the voodoo series lost its cache soon
after version 3 came out. Heck, I’m still
using dual voodoo 2’s in one machine, and a
3 in anoter, and can’t tell them apart.
And if I ever stick another Radeon in my
machine, it will go black again, unless I
totally tear apart the machine and re-build
the hard disk from scratch.

I’m going into carpentry or something. This
computer thing is looking more and more
depressing every year that goes by.

PS, for completeness:
This machine is running Win98 SE on a Tyan
Thunder 400 motherboard (Via Apollo Pro 133E)
with AGP 4x enabled; a P-III 733 and 256 MB
or RAM. Running the latest drivers for all
the other components (mobo, sound, net etc).


Don’t blame ATI too much…

There were a lot of issues with the GeForce when it first appears (I still have the problem of random lock-ups if I want to use AGP 2x with my ELSA Erazor X2). Most of them were due to the motherboard manufacturers (not enough power for the AGP port !) and not nVidia though…

You can blame a bit of MS as well for trying to create ‘smart’-OSes…

I know how frustrating it is to find out that a brand new acquisition is crap… Sorry it happened to you !

Concerning GeForce, I have the GeForce drivers running under BeOS 5 Personal Edition ! They do not use HW acceleration yet but I thought that would be the next step… Who told you there would not be any driver for GeForce under BeOS ?

Best regards.


P.S. : that was a very interesting post !

Jeez, why don’t you write a book bgl?

You probably have some sort of hardware conflict with your Radeon card. Try going to AGP 1x, disabling fastwrites (Radeon doesn’t support it), take out unneccesary PCI-cards etc.
Hope it helps.

I uninstalled my Matrox G200 drivers, took out the card, plugged the Radeon in.

Plopped the CD in the drive, pressed ‘okay’ a bunch of times and there you go - worked fine.

Do you have a BX chipset motherboard? I don’t care what anybody says, BX motherboards still ‘rool’ (dude, ahem) for reliability and stability.


The general problem these days is that many of the popular chipsets (and/or their GART drivers) are buggy as all hell, and that the motherboards don’t meet the AGP spec… (sure, they may say they support AGP 4x, but when the signals have more noise than the spec allows for and the timing is questionable, good luck getting it to work!)

Me? I don’t trust anything other than BX and 815. I use BX and get 100% stability with any of our released drivers. My development system (Win2K) had a 2-month uptime this summer – the only reason I had to shut it down was that the power was being turned off.

  • Matt


This summer, didn’t you switch your system off to unplug your GeForce 2 GTS Ultra in order to plug in your GeForce 3 XXX YYY ???


P.S. : my system runs on a BX too: Gygabyte GA-6BXDU (Dual Pentium 3 600Mhz)… It is supposed to be OK concerning the AGP but I still have lock-ups if I run AGP 2x (no matter the OS !). Perhaps that’s actually my Erazor X2 that is faulty !

When ATI sent me that Radeon card 64 DDR DVI for free (in order to write the OpenGL BeOS Vs Windows article on BeNews), I rushed to put it on my PC, first under Windows98. I tried to install every possible driver, but I was getting the error message: “You don’t seem to have a Radeon card installed” and then the installation program was exiting!!
So, I installed the drivers manually, by unzipping the .exe ziped archive that contained the drivers and hacking the .inf file to figure out what .dll goes where! It was a nightmare, but it worked. I hope ATI makes some effort to eliminate as many bugs as they can.

Eric wrote:
> Concerning GeForce, I have the GeForce drivers
> running under BeOS 5 Personal Edition ! They do
> not use HW acceleration yet but I thought that
> would be the next step… Who told you there
> would not be any driver for GeForce under BeOS?

Eric, if you knew who Bgl is and what his relation with BeOS is, you wouldn’t ask such a dump question.
And just to second Bgl, don’t expect 3D drivers for BeOS from nVidia. Nvidia is snobbing BeOS, and they don’t want to make the drivers themselves neither give the specs to Be.
The updated 2D nvidia drivers that appeared for BeOS a month ago, are a hack/port of the Linux Xfree3.3.5 drivers. But the 3D part of those cards for linux are not open source, so, forget Hardware GL on BeOS with a Geforce or TNT1/2.



forget Hardware GL on BeOS with a Geforce or TNT1/2
Unless some Linux/Be guru takes on the tall order of creating a driver interface to allow Be to use the Linux binary. An unlikely scenario I know, but still a possibility however remote it is. Keep hope alive!

My development system has an original GeForce 256 (SDR) in it. I’d rather not even open up its case.

Now, my test machine, on the other hand, gets cards swapped in and out on a daily basis, and thus its case stays open permanently and its uptime stays low.

I’m the last person you should be asking for tech support about system stability issues, but I remember reading that some of the early Gigabyte BX boards have a “Voodoo3” jumper that needed to be set so they could meet the power consumption needs of V3. Since many newer cards eat far more power than V3, if you don’t set that jumper right, it causes stability issues.

Both of my BX’s are Intel SE440BX-2 boards. Never had any trouble with them, nor with the Asus P2B’s that powered my previous systems before these ones. I trust BX. I (mostly) trust 815. I do not trust 820/840, nor do I trust anything Via, ALI, or SiS make, and I also do not trust any of the current Athlon chipsets. Hopefully the 760 will be an improvement over the current Athlon chipsets. (The Athlon’s a good CPU – if only it had a good platform to go with it!)

On the topic of BeOS, I’m not in a position to comment.

  • Matt

DFrey wrote:
> Unless some Linux/Be guru takes on the tall order
> of creating a driver interface to allow Be to use
> the Linux binary.

That won’t happen. BeOS is just too different from any Linux/BSD system (see: BeOS is not unix or Mach-based, it is a brand new OS). X doesn’t run on BeOS, and DRI is too close to X.
Also, BeOS’ OpenGL is fully multithreaded and having said that, I don’t expect someone to emulate X on top of BeOS not even in 50 years from now.

Mcraighead wrote:
> On the topic of BeOS, I’m not in a position to comment.

Ok, don’t comment here, but please buzz around at nvidia offices or meetings about supporting BeOS. It would be a shame BeOS to have almost the best OpenGL implementation on earth and nvidia cards not to work on it. I had a TNT2 and changed it for a Voodoo5 at some point (I tried G400 and Radeon too), just because of BeOS’ sake. And if nvidia reads a bit the forums, they will see a lot of BeOS users dumping nvidia, just because you are not supporting BeOS (the 5 million downloads or BeOS 5 comes to mind right now…).
For your reading interest comparing Linux/Windows/BeOS:


Quick BeOS Intro:

[This message has been edited by Eugenia (edited 10-26-2000).]

Thanks for all the emotional support :slight_smile:

Two hours in the Fry’s return meat grinder
later, I’m out an All-In-Wonder Radeon, and
awaiting an Elsa Gladiac in the mail
tomorrow. I can use the 2D drivers under
BeOS, and hopefully the install will be more
reasonable under Windows98SE. (I have other
BeOS supported cards in other machines, too,
so I can still test my stuff under BeOS GL)

Funny enough, this episode ALMOST tempted me
to get a GeForce 2 Ultra (there are places
that have them in stock for $475) but then
common sense overcame me and I saved the

As I said, my motherboard was a Tyan Trinity
400, which is an Apollo Pro 133A based board.
I’ve always found Tyan boards to be reliable
before, and this machine supported a Matrox
RT2000 combo before, so I doubt it’s a power


I had a weird black problem with my video card, once. After many, MANY black screens, the problem was fixed by clearning the PnP settnigs in my BIOS and eltting windows sort it out again. It worked for me, but it wasn’t for a GeForce card.


Video Hangs When Running 3D Graphics Programs
cause by incomplete microsoft driver support for VIA chipset…

Just send your pc to hell with all it’s Microsoft crap and buy a Mac ,
OS X is going to change the way people
look at macs
I use a 500 Mhz G4 with 3 video cards
(Ati Rage 128, Ati Nexus 128 & 3DFX Vodoo 5500 ) all at the same time, all
working in peace & harmony.
No installation conflicts
I just can’t understant why you windows guys want to have a life full of disappointments.

Originally posted by cartilago:
Just send your pc to hell with all it’s Microsoft crap and buy a Mac ,
OS X is going to change the way people
look at macs
I use a 500 Mhz G4 with 3 video cards
(Ati Rage 128, Ati Nexus 128 & 3DFX Vodoo 5500 ) all at the same time, all
working in peace & harmony.
No installation conflicts
I just can’t understant why you windows guys want to have a life full of disappointments.







Eh hem… heh… umm… sorry. Hehehe…

Thats a good joke.

Heh heh…



About the initial post, I had problems with ATI’s drivers as well. The initial problem was probably due to the drivers but the second set of drivers you got probably would have solved the problem. I had massive D3D problems with my XPERT 128 until I downloaded ATI’s latest patch. After installing and rebooting the computer, all I got was blackness without running anything. After getting into safe mode I was able to change the display drivers so it would start up in 640x480 and then in the video setup saw that the installation of the latest patch had created a whole new set of drivers to choose from. I choose the correct one and restarted my computer and it worked fine. The problem was that the installation choose the wrong driver for my computer and caused the blackness. Maybe the patch you downloaded had drivers for more than one version of the Radeon and the installation thought you had the wrong type, thus making it incompatible with your computer. Since the drivers will remain in Windows, after you get in safe mode you can change them and select the one that correctly corresponds to your card type.