Texture problems with new Nvidia driver

After upgrading my GeForce FX 5900 Ultra with the new Nvidia drivers 56.72 all my textures has got dark borders around them.
All problems dissapeares if I change back to the older 45.23 drivers.
Im wondering if anyone else got the same problem or if im the only “lucky” one.

Play with the “conformant texture clamp” option in the “Performance and quality” settings tab in the driver. You’ll have to enable the “show advanced settings” check box for this to be available.

If that affects your issues, your application is at fault, not the driver. Basically, you need to replace GL_CLAMP with GL_CLAMP_TO_EDGE. Older NVIDIA drivers interpreted GL_CLAMP wrong and gave you GL_CLAMP_TO_EDGE behaviour.
This option is in the drivers because a lot of older applications rely on this wrong behaviour.
With the new drivers “conformant texture clamp” is the default setting.

Changing your code is preferred over changing the driver option back to non-conformant. Think about the poor ATI/3DLabs/whatever users you might want to give your application to.

Thanx for your reply.

I maybe a nuthead but what the heck is GL_CLAMP_TO_EDGE. My compiler dont like it. Am I using old libraries here. :confused:


Download glext.h at http://oss.sgi.com/projects/ogl-sample/ABI/ it contains all the GL extensions #defines.

… and it should be in older headers as GL_CLAMP_TO_EDGE_EXT :slight_smile:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.