Texture Problem

Most users are not having problems with my application, but a good number of them still are. Here is what the problem looks like:

Where the black boxes are, the font should be. I am using OpenGL wrapped in SDL. I am using SDL to call the texture, but I have modified my code so that the texture is hard-coded and there is no SDL_Surface to OpenGL texture conversion. There is still no dice. Suggestions? Thank you!


Thank you for your response. Here is what I get from that: OpenGL Error: invalid enumerant I decided to place the code that prints an error after each “glEnable();” line. This happens after “glEnable(GL_SMOOTH);” is called. When I comment that out, I get a lot of underflow errors when I use glGetError();. What baffles me is why it is happening at that line and why the text displays properly for half the people who tested, but not the other half (rough estimates… I would say it works for more than just half). Thank you!

First of all, GL_SMOOTH is not a valid parameter to glEnable. I’m not sure what you wanted to do, maybe wanted to use GL_POINT_SMOOTH, GL_LINE_SMOOTH or GL_POLYGON_SMOOTH, but what’s for sure is that GL_SMOOTH is only a valid parameter to glShadeModel.

With that changed to one or all of the above, I get multiple occurrences of “OpenGL Error: stack underflow” instead of a single “OpenGL Error: invalid enumerant” error. It looks like I will have to do a lot of back-tracing to find the true root of this problem. EDIT: The “stack underflow” was due to the number of pops exceeding the number of pushes. With that out of the way, there is now a “stack overflow” that I am trying to take care of. EDIT #2: All of the errors are now taken care of. The only thing left is getting the shading back. It was smoother and more gray. This may be due to all of the other errors that were occurring, however.

Update: OpenGL is no longer detecting errors but the font is still not working for the people that it has not been working for.