Strange display problem with game

Hi All,

I have a small game I built using OpenGL. I tried testing it on several computers. The graphics look fine on 1 Linux machine and 2 Windows machines, however on the 3rd Windows machine, the graphics are not being shown correctly. Basically, some graphics are “missing” or at least transparent. I updated the graphics driver, and that did not help.

I am lost as to how I should go about determining what the problem is. I want my game to run on all computers that support OpenGL. Is it possible I am doing something in the code that this particular OpenGL implementation does not support? Does anyone have any suggestions of things to try?

I really really appreciate any advise!



When you write an application you should be aware of what functionality you’re using.
If for example, you were using OpenGL 2.0 specification when writting youg game, you’re likely to use something that will run only on OpenGL 2.0 compatible GPU’s.

Try using a tool like glintercept - read it’s documentation to find out how to configure it to report all errors.

Thanks for that suggestion! This tool looks really good. I had no idea it existed. Looks like it’s also useful for performance tuning. I ran it on my game, and it didn’t turn up anything odd.

I am using OpenGL 1.1, so I doubt I would have this incompatibility with any driver. Any other suggestions?

On second thought…

glEnable(GL_RGBA) glGetError() =GL_INVALID_ENUM


Now run this on the machine that doesn’t show your game correctly.

Well… unfortunately that didn’t fix the problem. :frowning: The 1 computer still has issues. I don’t have any more errors in the log file. The only thing I know to do is some trial and error on that computer and hopefully I will stumble across something.

Perhaps the drivers are not conforment. Perhaps you can tweak some values and see if the missing graphics shows up. It depends on the GPU and what you are doing in your code.
Intel integrated stuff usually has problems.

Funny you mention Intel. That’s exactly what I am using! Turns out it was a driver related problem after all. I did not reboot the computer after updating the driver ( because it didn’t tell me too and I didn’t think of it ) I just happened to reboot and now it works. So unless it just magically fixed itself, that is the only explanation that makes sense. Thank you guys for your contributions!