Stencil buffer crash with geforce & sdl

i’ve a small prog using the win32 api under win98 ,where i use the stencil buffer and it works fine, but i’ve tried to do the same under linux, with the sdl and at the init , there is an error
>GLX is unable to satisfy your request.
but i’ve the last nvidia drivers(under redhat 7.3)
maybe i’ve done something wrong at the install

i don’t know where the problem is…maybe you know??
PS:i’m french an newbie of linux, so please be nice )

use glxinfo to see which pixelmodes you have hardware acc… then compare to your request to SDL.

ok, i’m going to try, but if they don’t match, how can i change them??

Originally posted by Mad Martigan:
ok, i’m going to try, but if they don’t match, how can i change them??

Your program works in win32 so it should work in Linux with the same hardware, too. It is possible that you just did not set the required video mode for your X server. Take a look at /etc/XF86Config to find out if your desired resolution is available and if not just add it.

the problem is not from the resolution but from the stencil buffer…i’ve tried glxinfo but i do not understand everything, where can i find some help(???)

Perhaps I got something wrong, but I thought stencil would depend on your bpp.
So let’s try it the glxinfo way. Tell us its output and what pixelmode you request. Without more information we can’t help, sorry.

…ok, i’ve got glxinfo working and understand and…ARGH
it displays 4 mode…on the stencil size is set to 0 for all of them…
is there a way to modify this???

Originally posted by Mad Martigan:
is there a way to modify this???

I don’t know of any, sorry.
btw I have 16 modes with 8 including an 8 bit stencil buffer on my Geforce2MX.
Perhaps it is a problem of some wrong configuration or your driver installation. But you give very little information so it’s only guessing.
Does your renderer and vendor string show up correct in glxinfo.
Do you have direct rendering?
Is your XF86Config set up correct?

what is direct rendering(linux newbie…;o)
all my other opengl app work fine so i think XF86Config is well configured…
but my question is simple:
what are the ways to modify the data return by glxinfo(reinstall the drivers???which file to modify??)
i’ve check XF86Config and i’ve not seen anything about stencil buffer or glx configuration(exept Load “glx”)
is this normal…?
where can i find exemple file of this one to compare???

A sample XF86Config is included in the NVIDIA driver.
I never had problems like yours therefor I don’t know if you can change anything of the pixelmodes. I just installed the drivers and got all the pixelmodes I need.
I am really out of ideas.
One thing I can say is that all my pixelmodes which support a stencil buffer are 24 bpp modes.
So perhaps you only have 16 bpp modes.

Direct Rendering:
The X server is not used as a proxy for rendering comands but they are sent directly to the graphics card.
glxinfo tells you if it is enabled or not.

Perhaps you may also want to try the mailing list at

good luck

hey, thanx, i’ve fix it…but i so simple that i don’t think of it…it’s you with you 16/24bpp who makes me think of it…my desktop mode was 16 bpp so i’ve got only 4 modes without stencil…i modify XF86Config to have default value to 24 and now i’ve got 8 modes with 8bits stencil buffer…

thanx for everything guys!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.