Soldier of Fortune, MPEG

Ok, I have PII 450, 13G, 128MB RAM, 32MB 128 Rage Pro, and I’ve installed DirectX 8, and all the latest drivers. I got Soldier of Fortune for Christmas and I installed it and OpenGL came with it so it required to be installed so I installed it. I played the game immediately after installing everything and it worked perfectly fine, and I got fairly far actually. (I also got a Quickcam if that has anything to do with it. I installed it before SOF) Anyways, I think once my computer was rebooted the system files “kicked” in or whatever and changed some things because now whenever I try to launch SOF it sits at a grey screen then I have to reboot. Also, it now does the same to Half Life and Omikron and my MPEG’s won’t work - windows media player pops up but it just says Opening… and it does nothing. I installed this Tweaker and it did nothing but screw up my icq so I tryed to uninstal the tweaker but there’s no damn uninstaller. Anyways, I emailed the company and they said for me to run DXDIAG so I tryed to but nothing showed up , although if I press control-alt-delete I can see it there in the list. The Mpeg’s do that as well, every time I try playing another one it leaves another Mplayer2 in the list. So I uninstalled ALL my games and OpenGl then went into Windows Registry and got rid of everything to do with OpenGl then restarted. Still no fix. Does anyone have any ideas? Please help me this is driving me crazy!


I have had a very similar experience. I also got SOF for Christmas. I also did the GLsetup business, downloading the latest version (117). And then I got the grey screen as soon as I tried to play the game.

I then removed GLSetup in add/remove programs. The problem remained. Then I tried to uninstall SOF, but it says the sof.isu file has been corrupted, so I can’t uninstall.

I also can’t reinstall the GL files because my GLSetup says it can’t contact the network server, so there’s clearly something left over from my old GLSetup on the system.

But one piece of good news. The activision web site gave some advice on the grey screen problem in SOF. By closing all programs except explorer and systray, SOF then starts okay.

All I have to do now is clear up all the other mess and get OpenGL working again, cos my graphics now leave something to be desired. Any suggestions? Glen.

Yeah, I went to the website and found that exact page. I did exactly everything it told me to do and it still would not run. This is driving me insane…and once the problem is fixed I’m still gonna want to play SOF and I will install it again. Does your MPEG’s work alright?

Yes, my mpegs work fine. So maybe our problems are different after all. I’ve tried phoning tech help at Activision, but I’m put on call-waiting. I gave up after ten minutes. Have you tried them.

No, I haven’t tried calling them. It’d cost like 10000 dollars just to get them to help me because it’s long distance. I live in Canada and it’s in the US. They probably wouldn’t even solve my problem. Another thing is my DXDIAG does’t show up whenever I try to launch it. But whenever I press control alt delete I can see it in the list. I’ve gaven it minutes to load and it still doesn’t. So I dunno what to do. I think are problems are fairly the same. I think I’m gonna have to end up reformatting my hard drive.