Setting up Collada Dom question

Hello

Using Visual Studio 2008 I am trying to set up collada dom by following the “Setting up” guide here. Currently the only compiler issue I am getting is this

fatal error LNK1104: cannot open file 'libcollada15dom22-sd.lib

Can anyone help me with this please? I have included “libcollada15dom22-sd.lib” in the Linker->Input->Additional Dependencies; so I cant think at the moment what could be wrong. Any ideas or solutions would be appreciated.

Thanks

Have you shown it the path from where it can pick up that .lib ? In essence, the folder where you have the file stored, is VS able to look in that place?

I would belive so. But I looked in the dom directiory for the lib but couldent find it. But this seemed to work. libcollada15dom21-d.lib. Im getting this issue now and am not sure what to do to fix it. I do appreciate for what information the setup guide gives but it would seem that it may need to need to be modified to more accuaratly state on exactly what has to be done.

Error 3 fatal error C1083: Cannot open include file: ‘boost/filesystem/convenience.hpp’: No such file or directory d:\documents and settings\michael wojcik\my documents\programming\collada\collada-dom\dom\include\dae.h 28

Does anyone know what I can do to remedy this?

Thanks!

This time its the problem with your include directories. VS can’t seem to find the boost folder. In your include directory property (in VS), try specifying the location of boost and see if it helps.

Either define the NO_BOOST build flag or install Boost.

Thanks for the replies guys.

I made sure that I was including the correct includes and included the NO_BOOST build flag and it seems to be working now :). My concern though, is that having no boost installed a disadvantage? I tried to install it first but couldent really figure out how. Is their perhaps some documentation around that could guide me through the process? Most of my installation experience comes from installation wizards so Im a bit new on ‘manually’ doing it.

I recently read the collada book and am excited to start supporting it in my game engine. Off to the tutorials then :). (Already read Creating documents and I thought it was very well written)

You don’t have to do much to install Boost. Its all in their headers! Just download and point your includes to their root and voila you’re done.

You’d need to compile some of there systems only if you use them. Its really simple. I wrote this sometime back:

http://entropologygames.wordpress.com/2009/09/29/how-to-install-boost/

Hope this helps!

PS: I PM’d you!

Thanks brainydexter for the info. Unfortuantly though I cant seem to get it to work just yet. But there is good news! This is what I did

1: Include FilePath…\boost_1_40_0 In the Addtional Include Directory

2: Removed NO_BOOST from the preprocessor definitions.

The good news is that we got rid of the current compile errors :slight_smile: . But now I am getting linker errors such as…

Error 72 error LNK2001: unresolved external symbol “class boost::system::error_category const & __cdecl boost::system::get_generic_category(void)” (?get_generic_category@system@boost@@YAABVerror_category@12@XZ) AppPropertySheet.obj

Do I need to #include something? If so, what is it that I include?

Thanks!

Linker errors can be possibly because of something in your code or you are not including the right library files. I am not sure if boost does autolinking or not. I’d have to look at it. So you don’t need to include more headers, instead specify libraries in C++ > Linker > Additional Library directories.

Can you post your code if its not too big?

Boost is a useful programming library but it’s not required for the DOM to work.