Savage4+VIA+Win2k don't cooperate with Opengl

Ok. I’ve been everywhere, and gotten the latest drivers, checked all the boards, etc… It seems however that Opengl mode in Win2k doesn’t work with an S3 Savage4 card. Since I recently upgraded OS’s from 98 to 2k, I have a feeling the fault lies with S3, but I figure I’d get the best help here. Directx8 works great, AGP everything, but whenever an app runs Opengl, I usually see the first frame and then the computer locks up. This leads me to believe that Opengl could work, but due to some problem doesn’t. As a workaround to this, I deleted the s3micd.dll file which opengl needs run, and now, instead of locking up, I just get a little error message box which I can then bypass. However, I came here wondering if I could possibly get Opengl to run in software mode completely and how I would go about that.

I know this isn’t really related to this forum, but I had to post it somewhere alive…

I recently found a opengl32.dll over at but everytime I try to overwrite Win2k’s opengl32.dll with the directx converter from altsoftware, Win2k restores it! I’ve even deleted it and Win2k will just pop it back up. Very irritating…

[This message has been edited by hova (edited 02-04-2001).]

I would dump the savage card! I spent the last year trying to get the savage card stable to play games with or with out open gl. I never got the gl to work in a game too. If you read about the savage4 cards you will find most users have trouble with the card. I think this was do to a rush to market with the card just before they were taken over by diamond Corp. Surport drivers for the card now are poor at best. I ended up changing my card to a Radeon 32ddr, and wow what a differce, it’s the card i’m sure.

Ok. I somewhat solved the Savage4 problem. I put my old voodoo2 back in and now it runs Opengl in games fine. However, this raises an additional problem. The voodoo2 can’t render in a window, and while there are some glide hacks, there are no opengl hacks that will let it render in a window. (To remove the Savage4 opengl, I editied the registry and deleted the Savage entries under the keys Opengldrivers). I’ve tried taking the 3dfxvgl.dll and renaming it to opengl32.dll and putting it in said window rendering application, and as far as I can tell, it works except for the fact that the voodoo2 makes it go full screen. Not all is lost though, as this is a step up from the Savage4 which would just lock up my Win2k machine.