round points become a square points

The round points in my graphic turn to square points when I use a laptop to do my openGL. Why is this so?
Is there anyway to change it back to round points?

hmmm, what graphics cards are you using? I think nvidia support round points, don’t know about others.

Apparently there is big a difference between various graphics chips. See prior discussion on the opengl newsgroup

Try this example, “Multiple Viewports” at,%20MFC%20&%20OpenGL%20.htm

A “big” point appears in one of the viewports and it has worked on all accelerated nvidia hardware from a tnt2 to gf4 that I have tried.

Thanks for your help and explaination

If you have antialiasing disabled (or if the OpenGL implementation on your laptop doesn’t support aa) points will be rendered square. Using aa yields round points.

[This message has been edited by jmg (edited 10-07-2002).]

What is the value of your GL_POINT_SMOOTH_HINT?