RIVA TNT2 Ultra OpenGL -problem PLEASE HELP

I have a Riva Tnt2 Ultra running on a Celeron 466 MHz.
My problem is;
Whenever I run a OpenGL-game (half-life, quake2, unreal ) everything works fine…for a few minutes.
Then my system crashes, the monitor turns of and all I can do is reboot.
I upgraded my drivers to the newest ones fron Nvidia (detonator) aswell as i have upgraded all my games to the latest versions…I even re-installed Win98 (just over my old one) but without result.
I changed the fan on the grafik-card but nothing happens.
Still the same problem.
My computer is an:

Celeron 466
Intel 440BX AGPset GA BX2000+ motherboard
128 PC133 RAM
40 GB IBM-deskstar (running in a ATA(ultra)66-IDE)
Riva TNT2 Ultra 32 MB

Running at 2X AGP
Aperture size: 64 MB

Sometimes this can be solved by manually setting the AGP drive control value (if available) in your system’s BIOS setup program. Set it to manual, and try setting the value to EA (The default should be DA, but what does it matter? You’re changing it! :P). There are many other BIOS tweaks that should improve stability, such as Spread Spectrum. Look on the internet and see what you can find!

I did’nt find that in my BIOS, but tnx anyway :slight_smile:
This problem is driving me crazy…I should be able to play theese games without any problem!!
Is there something else I can try?


Sorry guy, i can’t give you any solutions, because i’ve just realized the same problems.

My nVidia TNT2 M64 is doing the same sh…

I am full of hope that yout by now have found any reason for that behaviour, havn’t you?

Please send me a reply so that i can benefit at least… please…


I’ve solve the problem now.
There might be 2 solutions.

S 1: Find the Pin on the motherboard often called JP20 and JP21. The name of this function should be “Close For Voodoo” (very important that the function-name is correct, check your manual) och set it on “Close For Voodoo 3/Geforce vga card” instead of “Open”.
That higher the voltage to the card so it doesn’t shut down when it handles heavy 3D-graphic.
Worked for me.

S 2: Check you cards IRQ-adress/number by opening preferences for My computer and dubbelclick on the system-icon.
If your graphic-cards IRQ share the same IRQ as any other cards/components that is your problem!
Find a unused IRQ (1-15) and set your card to that…I may have to do this in BIOS so check your manual on how to do that.

One of these solutions should work.

[This message has been edited by Shermine (edited 10-12-2001).]