Return To Castle Wolfenstein problem - OpenGL or Hardware?

Bought RTCW and when I run it I get this:

Wolf 1.0.0 win-x86 Nov 13 2001
----- FS_Startup -----
Current search path:
C:\PROGRA~1\RETURN~1\main\sp_pak2.pk3 (232 files)
C:\PROGRA~1\RETURN~1\main\sp_pak1.pk3 (1342 files)
C:\PROGRA~1\RETURN~1\main\pak0.pk3 (4775 files)

6349 files in pk3 files
execing default.cfg
couldn’t exec language.cfg
couldn’t exec wolfconfig.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
…detecting CPU, found Intel Pentium III
Bypassing CD checks
----- Client Initialization -----
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----

----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\System32\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using desktop display depth of 16
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…41 PFDs found
…hardware acceleration found
…PIXELFORMAT 3 selected
…creating GL context: failed
…failed hard
…restoring display settings
…WARNING: could not set the given mode (3)
…setting mode 3: 640 480 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (640x480)
Initializing OpenGL driver
----- CL_Shutdown -----
RE_Shutdown( 1 )
Shutting down OpenGL subsystem
…wglMakeCurrent( NULL, NULL ): failed
…releasing DC: failed
…destroying window
…resetting display
…shutting down QGL
…unloading OpenGL DLL

Q_strncpyz: NULL src

Any clue as to what the heck is my problem?

Running the latest XP cert. detonator drivers and even tried the drivers from card manufacturer.
Get same error even after I reinstalled 2 times.

Is it my system that has a problem or is it the game itself?

P4 1700 MHz
Samsung 256 PC800 RDRAM
Win XP Pro
Prophet II MX 64MB - do not buy this card
DetonatorXP 21.83 Cert. Drivers
DirectX 8.1
80, 40, 8 gig drives
SB Live Platinum
Viewsonic A75f
Custom Case

Try to run some other OpenGL games to found where to start searching.

same here,and in a lot of other forums too,some of us cant use xp and some opengl games…and i cant even install opengl drvs as online glsetup wont run in windows xp…

looks like still no fix

[This message has been edited by Max-UK (edited 11-22-2001).]

Thing I don’t get is the multi-player demo of it works great without a problem. All other games that use opengl are working fine also.

If you can run the demo now but not the full game does it sounds like something is wrong with the game or your copy of it.

I get this error when I try to run RTCW: “ChoosePixelFormat() failed: Cannot find a suitable pixel format.” I click the OK button and another error message appears: “Glide->OpenGL Wrapper: Cannot create OpenGL window!” The demo and other OpenGL games (Quake 3, Alice) work perfectly.