rendered model edges are jagged

im displaying some models and find that the sharp lines on the models are on screen as somewhat jagged. The model in question is for example a crane, with lots of straight lines along the boom arm. Is this a resolution thing, or perhaps some smoothing technique is required to smooth against the background.

I do have gl_smooth enabled

Screen resolution would be the cause. Try upping the resolution to over 1024x768 or enable anti-aliasing and the aliasing should be much less noticeabe.

// ville

how do you turn on anti aliasing in opengl,

thanks for the info

you can use the MULTI_SAMPLE_ARB extension.
go to NeHe and look up the Full Scene Anti Aliasing demo.