remove hidden surface

when i apply texture to the glutSolid* and rotate the object the texture don’t follow a rotation. i think that this problem coming up because the hidden surface isn’t remove.
how can i remove hidden surface with glutSolid* object?
if this isn’t the problem how can i solve this bad effect?

oh i forget
had you tried google

can you give me more info?
i’m trying to use cull but when i rotate the object the hidden surface don’t change.
What is CCW?

Counter-clock-wise. This means that a triangle is front/back facing based on the direction how you specify them: CCW or CW.

You have to enable culling and specify what to cull by specifying what triangle you consider front/back facing.