"RedBook" v4.3 e8, can't compile src code


I recently purchased the “RedBook” openGL programming book. I’ve been trying to compile the source code from the website listed in the book (I can’t post a link but it is sort of like "opengl-redbook . com "), and I am getting no where. I noticed there was a Makefile included, so I tried working with that.

I typed:

mingw32-make all

and I get:

for d in 01 10 ; do ( cd $d ; mingw32-make all ) ; done
d was unexpected at this time.
Makefile:11: recipe for target 'all' failed
mingw32-make: *** [all] Error 255

I also noticed there were VS Solutions available, so I tried loading them with VS 2012, but I got linker errors, so I tried to fix them but adding the proper includes to the linker in the project properties. Then I got a slew of errors such as this and I’m stuck

error C2039: 'translation' : is not a member of 'vmath

I’ve searched the Web and it seems many people get stuck trying to compile the official RedBook source code, and then they just use other tutorials. Is there any official tutorial for compiling this source code that comes with the most recent RedBook?

They mean “translate”, not “translation”. Correct the function name and you’ll not see this error anymore.