Quake 3 Engine problems

I can’t run anything based on the quake 3 engine (which seems to be common). Currently when I try to play Alice I get the usual error: GLW_StartOpenGL() - could not load OpenGL subsystem. I have a Voodoo3 2000 AGP. I tried updating my 3dfx drivers, got the same error, installed opengl from glsetup.com and got the same error still. This is getting quite frustrating. Some of the posts mentioned commenting out a line in win.ini but it doesn’t exist in mine.

Another interesting thing that I noticed in the Alice console is this: …calling LoadLibrary( ‘C:\WINDOWS\SYSTEM\3dfxvgl.dll’ ): failed. This dll doesn’t exist in c:\windows\system or anywhere on my hard drive. Is this the problem, or a result of whatever is already screwed up?

Here’s the part of my console log that has problems:

Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\SYSTEM\3dfxvgl.dll’ ): failed
…shutting down QGL
----- CL_Shutdown -----

GLW_StartOpenGL() - could not load OpenGL subsystem

I’m running Windows 98 SE with 128 megs of ram on a 5MVP3 AT Form Factor mobo.


Changing your graphics adaptor drivers to Standard VGA graphics. Then reboot your computer. The display should be 640x480x16, and look really ugly. Now install the latest refrence drivers and reboot. Then install DirectX 7 or 8, and reboot again.

I had the same problem with q3a, Download the q3a update 1.27g from www.quake3arena.com