puzzling build message "Error getting function data..."

Can anyone offer some insight into what might be causing this cryptic build message when compiling for my AMD HD 5770 on OS X?

OpenCL Warning : clBuildProgram failed: could not build program for device[0] 0x107501268 (ATI Radeon HD 5770) (err:-1)
[CL_BUILD_ERROR] : OpenCL Build Error : Compiler build log:
Error getting function data from server

My kernel handles the fluid solver update of one cell value. It currently compiles and runs as expected on the CPU. It has worked on the GPU too, until recently. I’ve tried reverting a few changes but the error will not go away.

I am running Mac OS X 10.7.3. My kernel is about 1000 lines, so a bit big to post. I do not use any image buffers / image pointer types. That’s the only google hit I’ve seen related to this error response. I’m not sure what else to check for.

I’m not even sure what level in the build process this error is coming from? I am still able to compile other kernels, so this is something specific to my code.

quick update. I tried to compile my kernel using NVIDIA’s implementation and it also failed. This time, no API error string. Just build-failure code returned.