probs with hardware acceleration

Hi there,
first of all I don´t program opengl myself - I programm in c,c++… - but I have to work with it a lot. So basically I post this for a college of mine. The problem we (he) have is that when hardware acceleration is turned on to 100% the opengl graphics look kinda rough with this stair-like effect on normally straight lines. Also we have some other bad graphic effects, like flickering. Today I noticed that a cube (measurments 1000mm long, 500 mm wide and 10 mm in height) when zoomed out turns into lines and looks like a zebra crossing. When hardware acceleration is turned off the graphics look just fine. We can´t find out what the problem is.
The system we have the problems with is a PII 350MHz, 128mb RAM with a Elsa Gladiac 511 GeForce 2 MX 400 with 64mb RAM. The OS is Win98. The latest Elsa and later on the latest Detonator drivers were installed but nothing seem to affect the problem.
I really hope someone of you can give us a hint where the problem might be.
Thank you very much in advance,

Sounds to me like your depth buffer resolution isn’t high enough. Try moving the camera near plane farther out and the camera far plane closer (You would have set these by calling gluPerspective or glFrustum). If you aren’t already using 32 bit color, that might also help a bit.


  1. Get the latest DetXP drivers
  2. Try using a depth buffer of 32 bits
  3. Use polygon offset for very close faces like that
  4. Your colleague is drawing two faces that are mathematically very close to one another (with respect to the viewport/perspective settings), and this causes Z precision problems. The use of polygon offset should fix this (but I wouldn’t know because I’ve never used it, but it functions as a sort of W buffer)… He shouldn’t even be drawing them so close.
  5. Maybe he’s drawing both sides w/o culling. Turn face culling on (only draws one side of the face), or draw one polygon.