Problem with pbuffers/frag. programs on ATI drivers

I’m having a problem getting pbuffers and fragment programs working with the latest ATI drivers.

I’m running Debian/sid on an ATI Radeon 9700Pro. I was using ATI’s driver version 3.2.8 with XFree86 4.2.1 with no problems: 8-bit and 16-bit pbuffers worked and fragment programs worked.

Debian recently released packages for XFree86 4.3.0, and I upgraded these packages. Afterwards, when I tried to test my application, I found that 16-bit pbuffers have a problem with precision, and I’m unable to create fragment programs. By ‘problem with precision,’ I mean that when I draw pixels into the pbuffer and then read them back out, I don’t read the same values that I wrote.

After upgrading to XFree86 4.3.0, I’ve tried two different ATI driver versions: 3.2.8 and 3.7.0. No luck with either one.

Has anyone else had these problems and been able to fix them? I’m really frustrated by this right now.

Thanks in advance,

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.