problem with opengl mix texture

hello I need help, I have a card nvidia riva TNT2 model 64/64 pro and when I try to play call of duty 1 I get the following error:
COD 1.0 build win-x86 Oct 5 2003
----- FS_Startup -----
Current language: english
Current search path:
C:\ARCHIV~1\CALLOF~1\main\paka.pk3 (41 files)
C:\ARCHIV~1\CALLOF~1\main\pak9.pk3 (149 files)
C:\ARCHIV~1\CALLOF~1\main\pak8.pk3 (235 files)
C:\ARCHIV~1\CALLOF~1\main\pak6.pk3 (3 files)
C:\ARCHIV~1\CALLOF~1\main\pak5.pk3 (4858 files)
C:\ARCHIV~1\CALLOF~1\main\pak4.pk3 (1668 files)
C:\ARCHIV~1\CALLOF~1\main\pak3.pk3 (1992 files)
C:\ARCHIV~1\CALLOF~1\main\pak2.pk3 (694 files)
C:\ARCHIV~1\CALLOF~1\main\pak1.pk3 (2642 files)
C:\ARCHIV~1\CALLOF~1\main\pak0.pk3 (12816 files)

File Handles:

30160 files in pk3 files
execing default.cfg
couldn’t exec language.cfg
couldn’t exec config.cfg
couldn’t exec autoexec.cfg
========= autoconfigure
configure.csv: using configuration 1200 cpu MHz 512 sys MB 32 vid MB
execing configure.cfg
cl_language will be changed upon restarting.
fs_basepath is write protected.
fs_homepath is write protected.
WARNING: No language string information available for english
Hunk_Clear: reset the hunk ok
…detecting CPU, found Intel Pentium III
Measured CPU speed is 1.60 GHz
System memory is 512 MB (capped at 1 GB)
Video card memory is 32 MB
Streaming SIMD Extensions (SSE) supported

----- Client Initialization -----
----- Initializing Renderer ----

----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘C:\WINDOWS\system32\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using colorbits of 32
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 32, 24, 8 )
…1 PFDs found
…hardware acceleration found
…PIXELFORMAT 2 selected
…creating GL context: succeeded
…making context current: succeeded
video card cannot set mode 640x480 because GL_MAX_TEXTURE_SIZE is only 128
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
----- CL_Shutdown -----
RE_Shutdown( 1 )

Hunk_Clear: reset the hunk ok

my pc: pentium 4 1.6GHz, 512 RAM, WIN XP, directx 9c, 66.93win2kxp,
I tried with the following software but failed to correct the problem (sci-tech)

Looks like you need to upgrade your video card