Problem with newer version of glext.h


I’m a new OpenGL-programmer (and new to c++, too), and I’ve been
trying to learn how to use extensions.

Now, I’ve been looking at the tutorials at (lesson
22), and I noticed a strange thing. The code there compiles with the
glext.h included in the download, but if I change it to a newer
version of glext.h, I get a compiler error…

syntax error : missing ‘;’ before identifier ‘glMultiTexCoord1fARB’

PFNGLMULTITEXCOORD1FARBPROC’ : missing storage-class or type

unexpected end of file found

The problem is reported to be with the line:

What do I have to change to get it to compile with the new glext.h?

Please help?


I also a newbie on extensions but i think you have some alternatives. One of the best is the Povahalev’s extension loading library: and look at its FAQ for using it.

I’d recommend you avoiding third party loaders, as they are often buggy & requires a lot of libs, licensing etc.
About problem, can’t answer you right now, but best way is to compare both glext’s and find lines that causes errors. Maybe that’s because GL1.4, or smthn, I have a feeling that NeHe site is verrrrry old (1999 or smthn) you have to check this out. And don’t be affraid to edit glext.h (as long as you know what you’re doing)

Get new version of glext.h from here
this is not newest one (i’ve download it Feb 19 and it missed ARB_fragment_program definitions) but your function present in that header.

I downloaded a gl.h for opengl 1.1, and then everything worked with the new glext.h. Confusing.

However, problem solved. Thanks for the help.