Problem with glutPostRedisplay and XCode issues


I am an OpenGL noob. I recently bought a MacBookPro and I downloaded XCode 3.2.5. I have a computer graphics assignment but I have a certain problem with the code. When I run the sample code on windows or Linux, the program runs smoothly. But when I run it on my Mac, it doesn’t display the .obj file’s data well( it doesn’t display the texture, I only see the polygons) and when I move the mouse while button pressed(used to rotate the object), all it displays is a black screen. It seems like glutPostRedisplay doesn’t work!
Also, when I try to launch the program from XCode it doesn’t work,even though it compiles without errors or warnings, I only get that message from the console:
“Debugger stopped.
Program exited with status value:1”
If I compile and run the program from the terminal it works! What am I doing wrong? I need to be able to work from my laptop. Please help! :sorrow:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.