Problem with glutFullScreen

Hi all,

I am experiencing a trouble with glutFullScreen.

My program would run and render properly if I run it windowed, but if I issued the glutFullScreen command before glutMainLoop, the program render into a black screen.

Does anyone have a similar problem? I am using glut 3.7


BTW, I am using VC 6++, Win32 console application.

I found that the rendering works fine with any below 800 x 600, but not beyond.

I also notice that the objects are actually rendered, just the palette is shifted (to a complete grey scale). It’s more like the graphics card has run out of texture memories or something. But I rebooted my PC with the same effect.

It’s an Creative GeForce 2 Ultra card. I wonder it’s a hardware problem…

But then I tried other programmes, the full screen works just fine.

This is going to haunt me for the rest of my life if I can’t figure it out.

Well, Z, I can’t honestly say that I’ve never used glut before.

If there is a way of checking whether the mode change was successful, then use it (ehem). Your card sounds like it should handle the mode changes no problem - check the pixel formats you are using, 16\32bit colour and the z buffer sizes.

Sorry, but I’ve no idea about glut!

Thanks for answering my question about picking

I tested on another graphics card. It works. So I am pretty much sure it’s a hardware problem.

Maybe I burn my texture memory accidentally. :stuck_out_tongue_winking_eye: