Problem with GL Extensions

More Info…SOLUTION FOR MOHAA (yes it works).
Found this solution courtesy of Copernic for the search, and for the solution. Thanks to all above for pointing in the direction…

// bind “Vsync on and off”
set Vsync_on "r_swapinterval 1; set Vsync vstr Vsync_off;vid_restart
set Vsync_off "r_swapinterval 0; set Vsync vstr Vsync_on;vid_restart
set Vsync “vstr Vsync_on”
bind F9 “vstr Vsync”

Just make a text file with the above included (cut & paste from here) and name it custom.cfg save in the MAIN directory now when you press f 9 it switchers between on and off! Problem solved! The game looks for a custom file automatically!

now…how to force v-sync in Q3?

Good to see you understand my english…

Thanks for the reply, I will try it then I get home…

Thanks, hope we can find something out on the rest of the problems…

Hmm… Ok. I found a really nice tweaking utility for Nvidia cards. It’s called NvHardPage. Basicallly lets you tweak tons of options, and I’m praying one of those options will remove my problem.

Ok, give us a reply !

Good Luck !


I’ve been having the exact same probs with tearing in Q3 based games. Switching off the GL extensions usually solves it but I don’t know of any other solution. I have been looking. It’s madness that the latest hardware and software has this bug!


Yes, it really crazy…but why dont everybody have it, whys is is just some people…? Is it the drivers ? I have tryed gf2 gf3 gf4…and hercules isnt hercules something else(ATI) ?

Originally posted by erot71:
and hercules isnt hercules something else(ATI) ?

Hercules is a 3rd party, and makes many different cards, not just Ati products.

Another tweakable thing I found.

In regedit, I went to HKEY_LOCAL_MACHINE /
SOFTWARE / NVIDIA / NVTweak and deleted the NoPages entry. This opened up two more tabs on my addditional properties entry that I never had before.

Remember to post if you guys find a solution! I certainly will.

Ok, I got the fix.
I called Dell Tech Support and got a guy to come and replace my card, and now everything is fine.

This may not be the fix you guys were looking for, but it definitely worked. Hope this helps someone!

Ok, good for you ! But I have tryed a lot of cards…dont help for me…but happy for you!

Actually, I have a problem too… I have a geforce 4 ti 4200, and I have no underwater textures in half-life! I haven’t tried anything based on Q3 engine, but i probebly wont if there’s these problems…